WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Twenty Fourteen "Nothing found" Homepage, but no sticky posts? (8 posts)

  1. SurvivalistWeng
    Member
    Posted 8 months ago #

    Hi all,

    I've recently set up a site running the Twenty Fourteen theme. It is a multilingual site running on Polylang. At present, I have 3 published posts and all of them have the "featured" tag to make the site look more exciting. I plan to move the "featured" tags around once I have more posts. None of said posts are set to be sticky.

    When I go to the home page, my slider takes a few moments to load, but, in the meantime, my English homepage says "Nothing found", as though I have no posts published. Bizarrely enough, my French homepage does not experience any such issues. It simply displays the only French post I have published in the slider and the main content area of the homepage. Frankly, I'd much rather have the slightly weird looking configuration of the French homepage for everything, rather than the worryingly blank "Nothing found" page, since it will start looking proper once I have more posts.

    Here are the versions of my site:
    English
    French

    Note that the directories are just artificial URL constructs created by Polylang. I don't actually have those directories in my site. Can anyone tell me what is wrong? I'm not sure if it's a conflict between the slider and the main content, or if it has something to do with Polylang. Chouby, if you're reading this and think that your plug-in might have something to do with it, please tell me if you have any ideas.

    Thank you all!

  2. Tara
    Member
    Posted 8 months ago #

    Have you tried:
    - deactivating ALL plugins temporarily to see if this resolves the problem. If this works, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can't get into your admin dashboard, try deactivating via FTP or SFTP or whatever file management application your host provides. If applicable, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old.
    - switching to the unedited default, core-bundled Theme (such as Twenty Twelve, Twenty Thirteen or Twenty Fourteen) for a moment using the WP dashboard to rule out any theme-specific issue. If you don't have access to your admin area, you can switch to the default theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using via FTP or SFTP or whatever file management application your host provides. Alternately, you can remove other themes except the default theme. That will force your site to use it.
    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).
    - If the above troubleshooting steps fail to resolve the issue, try manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones. Read the Manual Update directions first!
    - Always backup everything (including your database) before doing any actions, just in case.

  3. SurvivalistWeng
    Member
    Posted 8 months ago #

    After going through the "deactivate all plugins" step, I'm reasonably sure that it has something to do with Polylang or the Twenty Fourteen theme itself. When I deactivated Polylang, everything came together on one home page and, somehow, it seems that the French post was not considered a "featured" post, even though it had that tag. Maybe it has something to do with how Polylang links 2 different translations of the same post? The only issue I have is that I do not know whether Twenty Fourteen is supposed to allow "featured" posts to appear in the main content area as well as the slider by default, especially since I just started using the slider yesterday. Does anyone know what the default settings for "featured" posts are in Twenty Fourteen?

  4. Chouby
    Member
    Posted 8 months ago #

    The only issue I have is that I do not know whether Twenty Fourteen is supposed to allow "featured" posts to appear in the main content area as well as the slider by default

    I confirm that Twenty Fourteen removes the posts from main content when they are featured.

    Up to now I made nothing to adapt Polylang to Twenty Fourteen and so there are some glitches. For example, you tag an Englis post as featured. Polylang makes the French translation appear in the slider, but does not remove the translation from main content. I will try to improve this in future versions.

  5. VikkSimmons
    Member
    Posted 7 months ago #

    I'm going to chime in too, and say that apparently it's the Twenty Fourteen theme itself that is the problem. I don't know what Polylang is but I don't have it and I couldn't get the posts on the home page as long as it was a featured and stickified post for the grid.

    I don't know why this isn't noted in big letters some where because the theme description makes you think you can do both. I wasted more than six hours on this problem as I couldn't find any info. I finally found this thread and had it fixed in an instant when I unclicked sticky and removed the feature tag.

  6. deepbevel
    Member
    Posted 5 months ago #

    I had to use a static home page to get featured posts without "Nothing found". but as with all static home pages it doesn't show the regular blog.

    Maybe they should just say

    "if you'd like to use the featured posts grid or slider, please select a static home page, then use this special tag to make the posts appear"

    then no one expects a static home page to show the blog. at least it would make more sense to me that way. I too spent an hour disabling plugins and trying different setting combos.

    Anyone notice how when using the featured posts, then changing "number of posts per page" in settings/reading, the featured posts tag goes back to default, if you changed it.

    It only occurred to me after I figured this featured posts thing out that posts per page does not apply. All you get are the posts you tag, and only on a static page. At least that's my experience. Hope it helps someone.

  7. bvo
    Member
    Posted 3 months ago #

    So to avoid "nothing found" under the grid, you have to select a static home page? One could make a empty static page, but still its a ugly solution.
    Is it possible, to juist show the grid on the homepage, so without a post of page under it? For me it would work to juist put all posts in the grid and/or use a menu.

    Regards,
    Bas

  8. esmi
    Forum Moderator
    Posted 3 months ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

    I am now closing this 4 month old topic.

Topic Closed

This topic has been closed to new replies.

About this Topic