WordPress.org

Ready to get started?Download WordPress

Forums

Twenty Fourteen
[resolved] Twenty Fourteen - featured image spacing on frontpage (28 posts)

  1. G
    Member
    Posted 7 months ago #

    I have several pages but not posts. I have created a static page website using the default Twenty Fourteen theme. On each page I have chosen to use a Featured Image (the same image on each page). When the website is displayed, the front page shows the image spaced down quite a bit (with blank lines between the menu bar and the image) but other (non-front) pages show the image hard up against the menu bar as I would have expected. What is making the alignment different on the front page? How do I get around this issue? Thanks

  2. Hi there, if you could provide a link to your site it will be easier to help. Thanks!

  3. G
    Member
    Posted 7 months ago #

    I need to tweak the site slightly first though to remove a few business names as this is a new site. I will post a link shortly. Thanks for your help.

  4. deKay
    Member
    Posted 7 months ago #

    Make a child theme and add this to the CSS:

    .content-area, .content-sidebar {
    	padding-top: 0;
    }
  5. G
    Member
    Posted 7 months ago #

    Hi Kathryn,

    Here's the promised link. You will see that the pages 'FRENCH COURSES' and 'SPANISH COURSES' show the image hard up against the menubar but the 'ABOUT US' page shows the image lower down.

    The First Page setting is 'ABOUT US' and there is no post page.

    http://www.graphiq-design.com

    Many thanks

  6. Thanks for the link.

    If you have a look at any page on the demo site on WordPress.org or WordPress.com, you'll see that the space above the page/post content is actually what's intended. Screenshot:

    https://cloudup.com/cojCEisgT9P

    So the question is actually why there is no space above the featured image on your pages, such as this one:

    http://www.graphiq-design.com/?page_id=129

    Have you made any CSS or theme-file modifications or is this a default install of Twenty Fourteen? If you have, could you please try reverting back to a default installation?

    If that doesn't change anything, could you please try temporarily deactivating all plugins you're running? If the space appears, then turn them back on one-by-one to find the conflict.

    Let me know how it goes.

  7. G
    Member
    Posted 7 months ago #

    Thanks for the information. I note your comment about the spacing and looked at the image you made reference to. However, I also observed on the HOME page of http://twentyfourteendemo.wordpress.com that some images there were hard-up against the menubar.

    Anyway, the point is that the spacing is different on one page to that on another, which is not the desired result! I don't mind which it is so long as it's consistent.

    I have since created a completely new installation and have tested the Twenty Fourteen theme with a simple two page static site. The problem exists here too.

    The problem only happens when a Featured Image is present on the pages. Without a Featured Image all the pages have the same spacing.

    Within the Reading Settings, changing the 'Front page' changes the behaviour so that the page selected shows the spacing, while all the other pages do not.

    I have disabled all add-ons but the problem still exists!

    Thanks again for your help.

  8. G
    Member
    Posted 7 months ago #

    Please have a look at this too, which also shows the image under the menubar without any spacing...

    http://twentyfourteendemo.wordpress.com/default-page-templates/full-width-page-template

  9. Hi there, thanks for the additional information, most helpful.

    I spoke with one of the Twenty Fourteen developers and it looks like the missing gap on pages with a featured image using the full-width template - like the page you pointed out in the demo - is actually a bug in the theme. Those pages should have the gap as well, to be consistent with the rest of the theme.

    I filed a core bug ticket here:
    http://core.trac.wordpress.org/ticket/26694

    Anyway, the point is that the spacing is different on one page to that on another, which is not the desired result! I don't mind which it is so long as it's consistent.

    I think it would make sense at this point - since it looks like this will at some point be changed in the theme - is to apply the gap to the specific type of page which is missing it.

    Could you try adding this bit of custom CSS:

    .page-template-page-templatesfull-width-php .post-thumbnail {
        margin-top: 72px;
    }

    An easy way to add custom CSS like this is to install the Jetpack plugin and activate the Custom CSS module. You could also install a standalone custom CSS plugin, or create a child theme.

    Going one of these routes will mean your CSS won't be overwritten when you update the theme - though hopefully this particular issue will be fixed in the next version of Twenty Fourteen and you'll no longer need the custom CSS. :-)

    Let me know if you have any questions or need further help with anything.

  10. It looks like the theme designers actually meant there to be no gap on full-width featured-image pages when a static page is set as the homepage, and I see you've come up with your own workaround to remove the gap as well.

    If you still need any help, just let me know.

  11. hanskeer
    Member
    Posted 6 months ago #

    I have the same problem as G. When I look at G's site now is see that G solved the problem. How did you solve it G?

  12. hanskeer - could you please start a new thread, provide a link to your site, and let us know whether you want the gap or not? Thanks.

  13. hanskeer
    Member
    Posted 6 months ago #

    Hi Kathryn, Thnx for your reaction. My site is yllw.be and I don't want the gap on the static startpage. Do I still need to start a new thread or is it OK now?

  14. G
    Member
    Posted 6 months ago #

    Hi Hanskeer,

    I followed Kathryn's link (in her earlier posting) and came across the following link, which gives details of the solution. I then applied this to my system as an interim bugfix.

    https://core.trac.wordpress.org/attachment/ticket/26694/26694.diff

    Hope this helps,
    G

  15. G
    Member
    Posted 6 months ago #

    Hi Kathryn,

    I meant to thank you for your help...

    "Thanks"!

    G

  16. swstretford
    Member
    Posted 6 months ago #

    Thanks - I had a few issues like this with spacing but resolved most. Thanks for the direction of where to look to fix!

    [Link removed]

  17. Glad most of you are set on this. If anyone still needs help, please start your own individual thread and provide a link to your site. Thanks.

  18. hanskeer
    Member
    Posted 6 months ago #

    Hi Kathryn, I started the individual thread now. I still cannot get rid of the gap above the featured image on the static startpage. I'm using the twenty fourteen General, -Content and FitVid options. Jetpack is installed also. I Would appreciate your help. My website is yllw.be. Thanks.

  19. Zulfikar Nore
    Member
    Posted 6 months ago #

    @hanskeer - if you are using the fourteen extended plugin then that feature is coming up in the next revision due on Monday.

    If you can not wait till then please post in the plugin forum and I'll link you up with a beta version.
    http://wordpress.org/support/plugin/fourteen-extended

  20. hanskeer
    Member
    Posted 6 months ago #

    @Zulfikar - Thanks a lot. I'll wait until the next revision of the extended pluging is released.

  21. hanskeer - I provided you with the necessary CSS in your other thread.

  22. hanskeer
    Member
    Posted 6 months ago #

    @Kathryn - Thnx again.

  23. hanskeer
    Member
    Posted 6 months ago #

    @ Zulfikar - In installed the new revision of the extended plugin. I'm afraid now, when I check the box to remove the white space above content, only the static page is fine. On the other pages the featured image gets partly chopped off. For now I keep using the work around Kathryn gave me.

  24. Zulfikar - glad the CSS fix works for you.

    The best place to report issues with the plugin is in its own forum:
    http://wordpress.org/support/plugin/fourteen-extended

  25. hawkmax
    Member
    Posted 5 months ago #

    None of the fixes seem to work for me. Or I should say it works but causes all sorts of other formating errors in the process. I'm using an otherwise empty child theme pointing to an unaltered twenty fourteen mother.

    http://wse22552.web42.talkactive.net/wordpress/

    I'm new to wordpress so I could be making a basic error!

    Isn't it enough to just add the suggested changes to the child theme's style.css?

    /Max

  26. Hi Max, would you mind starting a new thread for your issue and dropping a link to it from here so I see it?

    This thread is already marked as resolved and has gotten a little long, so it'll be easier to help you in your own thread. Thanks!

  27. centralmonterrico
    Member
    Posted 1 month ago #

    I have a very big white space appearing just before the featured image in all my pages in twenty fourteen theme can someone help me arraging this, i appreciate it very much. this is my site

    http://www.central-monterrico.com/

  28. centralmonterrico
    Member
    Posted 1 month ago #

    I have a very big white space appearing just before the featured image in all my pages in twenty fourteen theme can someone help me arraging this, i appreciate it very much. this is my site

    http://www.central-monterrico.com/

Reply

You must log in to post.

About this Theme

About this Topic