WordPress.org

Ready to get started?Download WordPress

Forums

Tweet Blender causing problems? (5 posts)

  1. ArgentinaElections
    Member
    Posted 2 years ago #

    Hello. I have been having serious issues with my site crashing for the past few weeks and now that I am receiving way more visits it crashs almost all the time. Besides having a probable spam issue (checking on that still) I realized that the plugin Tweet Blender might be causing a problem. I got this:

    [Wed Aug 03 07:40:46 2011] [notice] mod_fcgid: too many
    /home/jonasete2001/argentinaelections.com/wp-content/plugins/tweet-blender/ws.php
    processes (current:20, max:20), skip the spawn request

    And I checked online that other people had similar issues:
    http://getsatisfaction.com/tweet_blender/topics/tweet_blender_causes_100s_of_mysql_requests_second
    http://www.eukhost.com/forums/f24/worst-hosting-support-ever-11380/

    Does anybody have ideas/tips/suggestions about this plugin?

    Best

  2. kirilln
    Member
    Posted 2 years ago #

    To minimize load on caching web service (ws.php) in TweetBlender you can:
    1) refresh widgets less frequently
    2) lower number of sources blender (e.g. add users to a Twitter list and use that list as the only source)
    3) decrease number of widgets on you site

  3. popbox
    Member
    Posted 2 years ago #

    Tweetblender crashed our site so badly that we needed to migrate to a larger server and reconfigure much on the back end.

    My advice - DO NOT USE THIS PLUGIN!!!!

  4. kirilln
    Member
    Posted 2 years ago #

    @popbox: not sure I understand your post. When a site crashes, you can just disable the plugin - there is no need to "migrate to a larger server and reconfigure much on the back end".

    YES, WITH CACHING ENABLED, LARGE NUMBER OF SOURCES IN THE WIDGETS, FREQUENT REFRESHES AND HIGH TRAFFIC TO THE SITE YOU WILL HAVE REALLY HIGH SERVER LOAD WHICH COULD LEAD TO A CRASH.

    As I wrote above, you can take some measures to decrease the load on the caching system OR simply disable caching under WP Admin > Settings > Tweet Blender > Archive.

    Finally, as with any misson-critical site it is a standard practice to use a staging server to evaluate changes to the configuration. So before you install any new plugins I recommend you set that up and use that test site. That would help you avoid downtime.

    Bottom line, stop giving users bad advice and get your infrastructure and processes properly configured.

  5. Veerle Verbert
    Member
    Posted 2 years ago #

    @kirilln my website caused a server crash twice last week, due to numerous calls to
    GET /wp-content/plugins/tweet-blender/ws.php?q=%23emsoc&lang=all&action=search HTTP/1.1

    The refresh rate (widget level) was set on each 30sec, this was probably way too often..
    I'm glad I found this thread, I'd never tought the refreshing would cause such an enormous load. Seems a warning is at it's place in the widget interface & the admin page..

    fyi: i have two widgets on different pages on the site, each with the same source (only one hashtag, twitter list is not an option) and four tweets displayed. So the only thing I can reduce is the refresh rate

    For now I have deactivated the plugin, before I reactivate it, I want to test what effect reducing the refresh rate gives (can only be tested when limit is reached).

    It is a very nice plugin, so I hope my provider likes the test results ;)
    thx for your work!

Topic Closed

This topic has been closed to new replies.

About this Topic