WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Turning Off Autosave (10 posts)

  1. Dang Yankee
    Member
    Posted 5 years ago #

    When editing posts, the autosave feature saves the changes every few seconds. Whenever this happens, the window automatically scrolls to the top and I lose the place where I am editing. How can I turn off this feature and do only manual saves? It's very cumbersome editing posts the way it's currently set up.

  2. Shane G
    Member
    Posted 5 years ago #

    Hi,

    Check with these steps:

    1) Open your wp-admin/post.php file and wp-admin/post-new.php files.
    2) You will find this line of code there:

    wp_enqueue_script('autosave');

    3) Add // to the beginning of this code.

    The autosave option will be disabled for your existing and new posts.

    Thanks,

    Shane G.

  3. Dang Yankee
    Member
    Posted 5 years ago #

    Worked like a charm! Thanks, Shane.

  4. speerga
    Member
    Posted 4 years ago #

    Is there any command or coding or whatever that could be inserted into wp-config.php to do this? It seems to me upgrading to a new version of wp would mean having to re-edit the post.php and post-new.php files every time.

    Of course, a great solution would be if the wp devs would recognize many folks would like to turn off autosave completely and give us that option.

  5. youngsmith
    Member
    Posted 4 years ago #

    I'm having the same problem since upgrading to 2.8.4 however I don't want to turn it off - just slow it down.
    And why does it have to jump to the top? Auto-save without re-loading the text? The interuptions are impossible!
    Thanks

  6. MichaelH
    Member
    Posted 4 years ago #

  7. youngsmith
    Member
    Posted 4 years ago #

    Thanks for the quick response Michael,
    The 1st link is unclear as to which file should be modified - and is it adding the line or changing 60 to 120?

    I did run across the setting in wp-settings.php line 527 & changed it to 600. No problems now - though not really getting a chance to autosave.

    Is it possible to fix the Top-Of-Page reload after auto-save???

  8. MichaelH
    Member
    Posted 4 years ago #

    The 1st link is unclear as to which file should be modified

    That link is about "Editing wp-config.php" so edit wp-config.php.

    Modifying core files such as wp-settings.php is not recommended.

  9. MichaelH
    Member
    Posted 4 years ago #

    Is it possible to fix the Top-Of-Page reload after auto-save???

    That really warrants a new topic.

  10. christernyc
    Member
    Posted 4 years ago #

    I've tried all the suggestions mentioned above and they didn't work

Topic Closed

This topic has been closed to new replies.

About this Topic