WordPress.org

Ready to get started?Download WordPress

Forums

Turn off the autosave already!!! (19 posts)

  1. christernyc
    Member
    Posted 4 years ago #

    I have been working with WordPress for sometime now and I've been reading a lot about how the autosave is such a pain in the a** when writing and editing, and it is! It autosaves every 3 seconds and jumps up to the top of the age we have to scroll back down to look for where we left off, this is a very annoying waste of time.

    I've tried the plugin wp cms post control - doesn't work.

    I've tried what's on http://wordpress.org/support/topic/295244?replies=10 - doesn't work.

    I've tried what's on http://www.untwistedvortex.com/2008/06/27/adjust-wordpress-autosave-or-disable-it-completely/ - doesn't work.

    I'm fed up, what does work already?! I see a lot of other solutions, but I've lost patients already, I was hoping someone had some insight on this problem and has found what really works.

    Sorry gang, I'm venting. Don't mean to come across as a jerk, but really, when will WP have this as a setting under 'writing' anyway?

  2. MichaelH
    Member
    Posted 4 years ago #

    Please post your wp-config.php file here, without your database password info of course, and maybe someone can spot the problem.

  3. christernyc
    Member
    Posted 4 years ago #

    Thanks for your reply Michael.

    I never given this info on a forum before, I hope I wasn't 'over paranoid' by holding back too much info, while at the same time I'm nervous maybe I didn't.

    Here you go -

    <?php
    
    /**
    
    * The base configurations of the WordPress.
    
    *
    
    * This file has the following configurations: MySQL settings, Table Prefix,
    
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
    
    * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    
    *
    
    * This file is used by the wp-config.php creation script during the
    
    * installation. You don't have to use the web site, you can just copy this file
    
    * to "wp-config.php" and fill in the values.
    
    *
    
    * @package WordPress
    
    */
    
    // ** MySQL settings - You can get this info from your web host ** //
    
    /** The name of the database for WordPress */
    
    define('DB_NAME', 'xxxxxxxxxxxxxxxxx');
    
    /** MySQL database username */
    
    define('DB_USER', 'xxxxxxxxxxxxxxxxx');
    
    /** MySQL database password */
    
    define('DB_PASSWORD', 'xxxxxxxxxxxx');
    
    /** MySQL hostname */
    
    define('DB_HOST', 'xxxxxxxxxxxxx.db.xxxxxxxx.hostedresource.com');
    
    /** Database Charset to use in creating database tables. */
    
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    
    define('DB_COLLATE', '');
    
    /**#@+
    
    * Authentication Unique Keys.
    
    *
    
    * Change these to different unique phrases!
    
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/ WordPress.org secret-key service}
    
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    
    *
    
    * @since 2.6.0
    
    */
    
    define('AUTH_KEY', '_8G*y1xxxxxx@G)xxxxxxxx');
    
    define('SECURE_AUTH_KEY', '_8G*yxxxxxxx@G)xxxxxxxx');
    
    define('LOGGED_IN_KEY', 'DkT3 /kk/O7*xxxxxxx)bf');
    
    define('NONCE_KEY', '$J98Mja9zqbS+xxxxxxxxx');
    
    /**#@-*/
    
    /**
    
    * WordPress Database Table prefix.
    
    *
    
    * You can have multiple installations in one database if you give each a unique
    
    * prefix. Only numbers, letters, and underscores please!
    
    */
    
    $table_prefix = 'wp_';
    
    /**
    
    * WordPress Localized Language, defaults to English.
    
    *
    
    * Change this to localize WordPress. A corresponding MO file for the chosen
    
    * language must be installed to wp-content/languages. For example, install
    
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    
    * language support.
    
    */
    
    define ('WPLANG', '');
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    
    if ( !defined('ABSPATH') )
    
    define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    
    require_once(ABSPATH . 'wp-settings.php');

    Thanks again!

  4. Jeremy Clark
    Moderator
    Posted 4 years ago #

    You don't have the AUTOSAVE_INTERVAL defined in your wp-config.php. You'll need to add it.
    define( 'AUTOSAVE_INTERVAL', 300 );
    This will change it to every 5 minutes.
    http://codex.wordpress.org/Editing_wp-config.php#Modify_AutoSave_Interval

  5. christernyc
    Member
    Posted 4 years ago #

    hmm, thanks. I'll give it a try, much appreciated!

  6. christernyc
    Member
    Posted 4 years ago #

    Not working, where do I put the code define('WP_POST_REVISIONS', false ); in my wp-config.php?

    Thanks again

  7. Jeremy Clark
    Moderator
    Posted 4 years ago #

    Disabling post revisions won't stop the autosave. You need to add the define I had in my first post. You can change the 300 to any value you like in seconds.

  8. rtcunningham
    Member
    Posted 4 years ago #

    That's what confuses people. The autosave revisions are completely different than the post revisions and are controlled by separate pieces of code.

  9. christernyc
    Member
    Posted 4 years ago #

    Is there are particular place I need to put it in my wp-config.php file? define( 'AUTOSAVE_INTERVAL', 300 ); is still not working. I put it under define ('WPLANG', '');

    I use Dreamweaver, and oddly, it's deading the whole page and telling me I am using Invalid markup.

  10. rtcunningham
    Member
    Posted 4 years ago #

    As long as it's above the part that loads wp-settings. Your code will change the autosave interval to 5 minutes. The code at http://www.untwistedvortex.com/2008/06/27/adjust-wordpress-autosave-or-disable-it-completely/ is a plugin that disables it.

    With post revisions, you can add define('WP_POST_REVISIONS', false ) right under or where you would put the autosave interval.

    I disable both on all my blogs, but I have one that doesn't want to behave (it's a mulit-author blog) no matter what I do, but the autosave interval is set to 300 (5 minutes) so it isn't too bad.

  11. christernyc
    Member
    Posted 4 years ago #

    Hey RT,

    Sorry to take so long toget back, and I thank you for all your help.

    As far as the plugin method you mention above, I've tried it already with no success. I will try again and get back to you.

    Thanks again, will report in soon

  12. Roy
    Member
    Posted 4 years ago #

  13. christernyc
    Member
    Posted 4 years ago #

    Hi Gangleri,

    Thanks, will give them a go. I've got them installed but I'm not sure if I should activate both at once, or try one at a time.

    Thanks!

  14. Samuel B
    moderator
    Posted 4 years ago #

    I use Dreamweaver, and oddly, it's deading the whole page and telling me I am using Invalid markup.

    you must use a plain text editor like notepad

  15. christernyc
    Member
    Posted 4 years ago #

    Ah samboll, I will use that method then to see what happens, thanks

  16. christernyc
    Member
    Posted 3 years ago #

    Hi guys,

    Thanks for all your help, I'm sorry to not come back in awhile for an update with the progress of this thread, and an update of what's working or not.

    Well, nothing has worked for me. I've tried all the techniques mentioned in the thread.

    BUT, something actually DID work. I don't know what did though...

    You see, I do all my page writing and editing in 'html' mode. I noticed that when I do go to 'visual' the the auto save has been turned off, so again, I don't know what procedure did it.

    Now my question and problem is this. How to I stop it from jumping up to the top of the page while editing in 'html' mode? It clearly isn't autosaving, but it is jumping up with every key stroke.

    Thanks!

  17. juanola5
    Member
    Posted 3 years ago #

    Hi christernyc,

    I have the same problem as you, and it is literally driving me crazy. When editing in "html", text keeps jumping to the top every few seconds wich makes your job a missery, as you have to scroll down and look for the text all the time. I cant belive wp has introduce this diabolic feature by default.

    Will you please let me know in case you find the way to solve this problem. Thanks

    Juan

  18. gadmin
    Member
    Posted 3 years ago #

    I need help as well! the fact is I dont even no what editor to look into. I don't have a edior labeled "wp-config.php" so do I just go to my "single.php" file instead? and if so what do I do to make it stop because this is getting really frustrating.

    Her is what I am working with in my single.php file.

    <?php get_header(); ?>

    <div id="leftandright">
    <div id="leftcontent">

    <div class="oneblog_top"></div>
    <div class="single_post">

    <?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>

    <div class="thetitle">
    <h1><?php the_title(); ?></h1></div>

    <?php
    $crossblock_postimage_disable = get_option('crossblock_postimage_disable');

    if ($crossblock_postimage_disable != 'true') {
    $rs_image_key = 'image';
    $thereisimage = get_post_meta($post->ID, $rs_image_key, true);
    if($thereisimage) {
    ?>
    <div class="post_image">
    <img alt="Post image of <?php the_title(); ?>" title="<?php the_title(); ?>" src="<?php echo $thereisimage; ?>" />
    </div>
    <?php
    }
    }
    ?>

    <div class="post_details">
    <span class="left">Filed in <?php the_category(' , ') ?></span>
    <span class="right"><?php echo $post->comment_count; ?> comments</span>
    <div class="clear"></div>
    </div>

    <div class="the_content">
    <?php the_content(); ?>
    </div><!--/the_content-->

    <?php wp_link_pages('before=<div id="multipage-links">Pages : &after=</div>'); ?>

    <div class="after_post_details">
    <span class="left">Posted by <?php the_author(); ?>   @   <?php the_time('j F Y') ?></span>
    <span class="right"><?php echo $post->comment_count; ?> comments</span>
    <div class="clear"></div>
    <span class="left"><?php the_tags('Tags : ', ' , ', ''); ?></span>
    <span class="right adminedit"><?php edit_post_link('Edit This Post','',''); ?></span>
    <div class="clear"></div>
    </div>

    <?php
    $zenverse_global_adsense_id = get_option('zenverse_global_adsense_id');
    $crossblock_adsense_afterpost_enable = get_option('crossblock_adsense_afterpost_enable');
    if ($zenverse_global_adsense_id && $crossblock_adsense_afterpost_enable == 'true'){
    ?>
    <div class="adsense-afterpost">
    <script type="text/javascript">
    //<![CDATA[
    google_ad_client = "pub-<?php echo $zenverse_global_adsense_id; ?>";
    google_ad_width = 468;
    google_ad_height = 60;
    google_ad_format = "468x60_as";
    google_ad_type = "text";
    google_ad_channel = "";
    google_color_border = "f5f5f5";
    google_color_bg = "f5f5f5";
    google_color_link = "555555";
    google_color_text = "555555";
    google_color_url = "444444";
    google_ui_features = "rc:0";
    //]]>
    </script>
    <script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script>
    </div>
    <?php } ?>

    <?php
    $crossblock_socialbookmark_disable = get_option('crossblock_socialbookmark_disable');
    if ($crossblock_socialbookmark_disable != 'true') {
    ?>
    <div class="blogsep"></div>
    <div class="extra_content">
    <h3>Share This Post</h3>
    <div class="socialbmark">

    "><img src="<?php bloginfo('template_url');?>/images/sb_rss.gif" alt="RSS" />
    "><img src="<?php bloginfo('template_url');?>/images/sb_digg.gif" alt="Digg" />
    "><img src="<?php bloginfo('template_url');?>/images/sb_twitter.gif" alt="Twitter" />
    "><img src="<?php bloginfo('template_url');?>/images/sb_su.gif" alt="StumbleUpon" />
    "><img src="<?php bloginfo('template_url');?>/images/sb_del.gif" alt="Delicious" />
    "><img src="<?php bloginfo('template_url');?>/images/sb_techno.gif" alt="Technorati" />
    </div>
    </div>
    <?php
    }
    ?>

    <?php
    $crossblock_relatedpost_disable = get_option('crossblock_relatedpost_disable');
    if ($crossblock_relatedpost_disable != 'true') {
    if (function_exists('crossblock_get_related_posts')) {
    echo crossblock_get_related_posts();
    }
    }
    ?>

    <div class="blogsep"></div>
    <div class="extra_content">
    <h3 class="left"><?php echo $post->comment_count; ?> People Putting Up Their Middle Finger</h3>
    <?php if ( comments_open() ) : ?>
    <div class="replyjump"></div>
    <?php endif; ?>
    <div class="clear"></div>
    </div>

    <?php comments_template();?>

    </div><!--/single_post-->
    <div class="oneblog_btm"></div>

    <?php
    endwhile;
    ?>

    <div class="sep"></div>

    <div class="below-post">
    <span class="go-left" style="width:280px;">
    <span class="bold">Previous Post</span>
    <?php previous_post_link('« %link') ?>
    </span>
    <span class="go-right align-right" style="width:280px;">
    <span class="bold">Next Post</span>
    <?php next_post_link(' %link »') ?>
    </span>
    <div class="clear"></div>
    </div>

    <?php
    else :
    ?>

    <div class="oneblog_top"></div>
    <div class="single_post">
    <h2>Not Found</h2>
    <p>Sorry, but you are looking for something that isn't here.</p>
    </div><!--/single_post-->
    <div class="oneblog_btm"></div>

    <?php
    endif;
    ?>

    </div><!--/leftcontent-->

    <?php get_sidebar(); ?>
    <div class="clear"></div>
    </div><!--/leftandright-->
    <?php get_footer(); ?>

    if ( $key == 'autosave' && $value == 'off' ) {
    //wp_deregister_script//('autosave');
    }

  19. cabridges
    Member
    Posted 3 years ago #

    Dunno if this will fix your problem, but turning on Compatability View in IE 8 solved this problem for me. Found a post about it here -- http://www.mydigitallife.info/2010/04/10/wordpress-editor-jumps-up-to-top-or-beginning-of-text-in-ie8/ -- and gave it a shot; worked immediately, which was fortunate for the continuing health of my laptop.

    If you're not using IE8, never mind :)

Topic Closed

This topic has been closed to new replies.

About this Topic