WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Turn off remove commenting (7 posts)

  1. zoks77
    Member
    Posted 2 years ago #

    I have WP 3.3.1 and I've turned them off in Settings > Discussion but they stil appear on each page.
    Why is this happening and why won't they go away ?

  2. antorera
    Member
    Posted 2 years ago #

    I think when you turn off the comments, it only affects any posts or pages created afterwards. All existing posts remain the same, so you would have to go in individually and turn them off.

    I'm not positively sure this is how it works, but I seem to remember that is what happened to me at some point.

  3. zoks77
    Member
    Posted 2 years ago #

    I don't know how to turn them off one by one, I don't see any option to do that...
    Please elaborate if you know, thanks.

  4. antorera
    Member
    Posted 2 years ago #

    It may be that the comments on the individual post are hidden. Go to a post. At the top you should see a button for SCREEN OPTIONS. Click on it and a menu will drop down. There you should see different checkboxes on what to show in your post. See if Comments is turned on or off. Check it if it´s not. Then scroll through your page and you should see a section on comments. Here you can turn off comments for that post.

    However, I'm now on 3.3.1 and now that I checked it, it looks different. I have to run off now but will check it later when I'm back. See if this helps get you closer anyway.

  5. antorera
    Member
    Posted 2 years ago #

    Sorry, I confused myself. What you have to turn on in the Screen options is DISCUSSION. Then scroll down and you will see a box for Discussion. In here you will see Allow comments. Uncheck to turn off comments for this post.

  6. zoks77
    Member
    Posted 2 years ago #

    Oh great, it worked, i forgot to check Screen Options ! :)
    Thanks !

  7. antorera
    Member
    Posted 2 years ago #

    I always forget too. I would think that it would be displayed by default and that you can hide them as needed.

    Glad I could help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.