WordPress.org

Ready to get started?Download WordPress

Forums

Turn off comments on posts older than one month? (11 posts)

  1. josalmon
    Member
    Posted 8 years ago #

    A friend of mine has been running WP on her blog for a few months now and wants to know if there's a way to automatically turn off the comments on posts older than, say, a month without losing the comments that are already on there.

    If this is possible, can someone let me know!

    Thanks, Jo

  2. The auto-shutoff comments plugin:
    http://wiki.wordpress.org/Auto%20shutoff%20comments

  3. Truth
    Member
    Posted 8 years ago #

    does that work for pages as well? I'm looking for one that only works in posts and not pages.

  4. This one works for Posts and not Pages. :) I have had it on my own blog for ... uh... scratches head... almost a year now.

  5. Truth
    Member
    Posted 8 years ago #

    Oh.. right,.. thanks :)

    Just a question, so if I installed this plugin now, like say I set the cut off date to 12 days, so my old posts which are older than 12 days will close off comments too, right?

    Thank you

    EDIT: I realise it doesn't work for older posts?

    On this page

    http://wiki.wordpress.org/Auto%20shutoff%20comments

    there's 2 part of code, I copy and paste the code which is the second part right? What about the first part?

  6. It should.

  7. Truth
    Member
    Posted 8 years ago #

    Erm, not working for me though :(

    Does it close off comments automatically after I activate the plugin? Or do I have to wait for some time?

    Edit: It worked after waiting for a while.. lol. thanks :)

  8. josalmon
    Member
    Posted 8 years ago #

    So I just copy and paste the whole thing into a .php file, save it and upload it to the plugins folder? or is it just the second bit of code?

  9. The second bit of coloured text, right under 04 July 2004.

  10. josalmon
    Member
    Posted 8 years ago #

    I've been testing the plugin on my blog but I've just discovered that it breaks my feed. When I activate the plugin, I get this message if load my feed in my browser:

    XML Parsing Error: xml declaration not at start of external entity
    Location: http://www.josalmon.co.uk/feed/
    Line Number 1, Column 2: <?xml version="1.0" encoding="UTF-8"?>

    But when I deactivate it, the feed works fine.

    Any suggestions?

  11. josalmon
    Member
    Posted 8 years ago #

    Anyone?!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.