WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] turn off Allow comments not working on edit post page (9 posts)

  1. humbleopinion
    Member
    Posted 2 years ago #

    I am using WordPress 3.3-beta4! I am having a problem turning off the allow comments on older posts from the edit post page. There was a recent upgrade to the site in the past few days and now it doesn't work. Any help would be greatly appreciated!

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    It might help if you described what the problem was/is.

  3. Graham Armfield
    Member
    Posted 2 years ago #

    I've noticed the same in 3.3 beta 4 and it's also true of pages.

    To recreate:

    1. Set the general settings to allow comments.
    2. Edit a page and uncheck Allow comments and then click on Update the save the page.
    3. I’m returned to the edit page again and the comments checkbox is checked again. If I view the page the comments box is still there.

    Not sure if it’s theme dependant but it happens on both twentyten and twentyeleven themes.

    Do you need more detail?

    Graham

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    I can't replicate this using Twenty Eleven & WordPress 3.3-beta4.

  5. I can't reproduce this either.

    Do you have ANY plugins?

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    Damaged database, perhaps? That would explain why the updated setting isn't being saved.

  7. Graham Armfield
    Member
    Posted 2 years ago #

    It's a fresh install running on XAMPP on Windows 7. I have no plugins apart from the two default ones and neither are activated.

    The 'Allow Trackbacks...' checkbox works as expected. And I can save content changes normally.

    I first noticed the issue on Firefox 8.0.1 but the same is true on Chrome 15.0.874.121 m - but wouldn't have expected the browser to be affecting it.

    Have just tried again to double check and I still have the issue.

  8. Jon Cave
    WordPress Dev
    Posted 2 years ago #

    I think this is fixed in current trunk, but was present in beta 4. See http://core.trac.wordpress.org/ticket/13473 and http://core.trac.wordpress.org/ticket/19349.

  9. That would be why I couldn't repro it, Jon! :D

    Okay, flagging resolved since this was fixed in trunk.

Topic Closed

This topic has been closed to new replies.

About this Topic