WordPress.org

Ready to get started?Download WordPress

Forums

WP RSS Multi Importer
[resolved] Tumblr Feed via yahoo pipes showing errors (8 posts)

  1. CallMeAndy
    Member
    Posted 1 year ago #

    Bit new to RSS in the nitty gritty, however using yahoo Pipes to filter and modify a Tumblr stream which I want to bring into WP as posts.

    On first loading the feed I get "This feed has errors"

    loads perfectly Ok in RSSOWl, and FeedWordPress

    http://pipes.yahoo.com/pipes/pipe.run?_id=995015e223f81dee87c00bfbef31e6c4&_render=rss&intPosts=50&strUser=adventurebods

    Can you advice me what the stumbling block is, and if there is a workaround.

    Cheers,
    Andy

    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

  2. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    Yes, I get an error message in the admin (that's means the feed is giving simplepie, that reads the url, an error), but it nonetheless renders ok on the web site, like here:

    http://www.wprssimporter.com/

  3. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Also, I think the problem for simplepie is that that the rss feed has an empty space at the end of the feed, see here:

    http://screencast.com/t/X3WpKbttyw

    This causes some readers problems. If you have access to control that feed, get rid of the extra space and see if that solves the error problem,

  4. CallMeAndy
    Member
    Posted 1 year ago #

    Ok thanks for coming back Allen.

    The empty space I dont think I have any control over. I believe it is a formatting issue with the way yahoo pipes bolts together the post elements.

    That aside I am still not getting any feed come through into the posts, the message "The most recent feeds have been put into posts" is posted to the admin window after using the fetch button, but nothing ariving in the posts tab. When you said it renders to the site do I assume your test was direct to a template without the draft post stage.
    Only I wish to bring in each post into a draft post.

    I dont know if it is relevent but I am using multisite. The WP is 3.5
    Thanks

  5. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Ok...here is a video of what my experience is...this is on a production server (bluehost) at allenweiss.com

    http://screencast.com/t/NrQ4VP8QS6w

    As you can see, the feed shows errors in the feeds panel (which means that simplepie had problems with it...now when using the Feed to Post, simplepie had to read the feed, but evidently the errors weren't so bad it couldn't be read.

  6. CallMeAndy
    Member
    Posted 1 year ago #

    Hi Allen,
    Yes this is exactly what I'm doing.
    Hopefully later today I will disable all the plugins and go to default theme etc and see if there is a conflict but a bit pushed for time at the moment.

    Your commitment to user issues is looking exceptional BTW, hats off my friend.

  7. CallMeAndy
    Member
    Posted 1 year ago #

    Allen - things interfered I'm afraid anyway back on the case earlier.
    So retracting my original statement as you said in spite of the error message the feed does render, so cool I can live with that.

    Thanks for your help.

  8. CallMeAndy
    Member
    Posted 1 year ago #

    Resolved

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic