WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Trying to setup URL mapping with ver 3.4.0b (4 posts)

  1. Jxff
    Member
    Posted 1 year ago #

    Steps I have taken:

    1. Setup subdomain at registrar secure.mydomain.com
    2. Pointing subdomain to my nameservers
    3. Setup subdomain in cpanel secure.mydomain.com without redirection
    4. Installed Postive SSL successfully for secure.mydomain.com
    5. Installed fresh install of WP 3.5.1 to /public_html
    6. Set permalinks to http://mydomain.com/sample-post/
    7. Installed dev version 3.4.0b of HTTPS plugin and enabled
    8. Configured HTTPS plugin SSL Host for secure.mydomain.com
    9. This automatically updated the first line of URL mapping to:
    http://mydomain.com to https://secure.mydomain.com and saved.
    10. Checked both Force SSL Administration & Force SSL Exclusively and saved.

    It seems that it only works after I copied my WP install to:
    /public_html/secure/

    My goal is to only have the admin pages on SSL that is configured for secure.mydomain.com

    What am I doing wrong? If I logout and go to mydomain.com and click on the login link I am taken to https://secure.mydomain.com/wp-login.php so the URL mapping looks like it is working. Do I need to enable redirection in cpanel for the subdomain secure.mydomain.com? If so to what?

    Thanks! Jxff

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Well, you're going to want secure.mydomain.com to point to the same public_html folder.

    Past that, I didn't actually catch what the problem was. What's not working how you want it to?

  3. Jxff
    Member
    Posted 1 year ago #

    Well, you're going to want secure.mydomain.com to point to the same public_html folder.

    When configuring the subdomain in cpanel you can enable or disable redirection. I have done both ways and I can not login as admin unless I copy the contents of my WP install /public_html to /public_html/secure. The secure folder was created when I setup the subdomain in cpanel secure.mydomain.com.

  4. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    I can't help you configure Cpanel, but the apache vhost needs to be pointed at the exact same folder, not a subfolder. Talk to your hosting provider to see if it's possible.

    So, do you have an issue?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic