WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Trying to setup a Japanese (UTF-8) WordPress system (5 posts)

  1. iangler
    Member
    Posted 8 years ago #

    I'm trying to setup a Japanese language WordPress system for a few of my friends and I have everything setup perfectly except for 1 thing I can't seem to resolve. I have wp-cofig.php and ja_UTF.mo installed and working. But for some reason the dates are not showing up properly. See this -> http://www.iangler.org/images/example.png
    As you can see from the image, the month is not showing up. Anyone know which file I can tinker around with to get this to show properly in UTF-8?

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

  3. iangler
    Member
    Posted 8 years ago #

    I've actually posted in the Japanese WordPress forums as well. It seems most people use EUC encoding for Japanese, and my setup is UTF-8. As you can see from the image I posted, UTF-8 works. It just doesn't show the date properly for some reason (the date is supposed to be in English, you can tell beccause it saids '10th'). I'm guessing it's an Mysql+PHP problem. Can someone tell me which file I need to be looking at to change these settings?

  4. moshu
    Member
    Posted 8 years ago #

    The date (time) format is defined in two places: in your admin panel > Options > General and in the template files.
    What you set up in the Options will display only if the template tags don't have any parameters, i.e. look like the_time ().
    I'd suggest check the index.php and the other template files of the theme and put the parameters you want. I bet you'll find an "S" in there (see http://ca3.php.net/date )

  5. iangler
    Member
    Posted 8 years ago #

    Thanks, I changed everything to the_time('n/j/Y l') and it worked like a charm! So it was the theme messing things up after all.

Topic Closed

This topic has been closed to new replies.

About this Topic