WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Trying to ignore a subdomain that existed before I activated multisite (5 posts)

  1. Iva
    Member
    Posted 4 years ago #

    Hello,

    I enabled multisite on a domain with one subdomain which was not a part of the WordPress installation and now that subdomain isn't showing.

    Its name is love. I tried to exclude it via .htaccess. Here's the code, am I doing something wrong?

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    RewriteCond %{HTTP_HOST} love.iva-is.me
    RewriteCond %{REQUEST_URI} !love/
    RewriteRule ^(.*)$ love/$1 [L]

    Thanks for any help you can provide.

  2. Try putting it in the banned names list under Super Admin -> Options.

  3. Iva
    Member
    Posted 4 years ago #

    I did that as well. I read all the documentation you and other people put up, and tried everything.

    When I put it on the banned names' list, it redirects to the main domain page. When I don't, it goes to a register new user page and informs me that I am currently not allowing registration.

  4. You or your host will have to rearrange the subdomain records so the wildcard one comes after the other one.

  5. Iva
    Member
    Posted 4 years ago #

    I will tell them ASAP.

    And I am glad that I didn't bother you with something super-obvious, knowing how much you help people out.

Topic Closed

This topic has been closed to new replies.

About this Topic