WordPress.org

Ready to get started?Download WordPress

Forums

WP Video Lightbox
[resolved] Trying to DISABLE autoplay on Vimeo videos (7 posts)

  1. iconoclastix
    Member
    Posted 3 months ago #

    Hi, I am using this plugin on my website and it seems to work great except for the autoplay...I've read through a lot of the other questions in here but no one seems to have the same problem I'm having.

    I have a video hosted on Vimeo.com that I want to link to from an image thumbnail on my homepage. While the image thumbnail and modal window seem to work fine, the problem I'm running into is that the video itself starts playing when the page is loaded, rather than when the modal link is clicked. In other words, the audio of the video begins to play as soon as you visit the page which doesn't make sense since you can't actually see the video until you click on the thumbnail.

    I tried adding '&autoplay=0' to my shortcode as other indicated that setting this to 1 would ENABLE autoplay but my goal is to DISABLE it.

    I checked the plugin settings page and made sure that the "autoplay" box is UNCHECKED. I also tried setting autoplay:false in the video-lightbox.js file but this didn't seem to solve the problem either. I've checked the embed settings for my Vimeo video and it appears as though the only way to control this is via the URL by appending '&autoplay=0' to the video ID like I have already tried doing.

    Here's my shortcode:
    [video_lightbox_vimeo5 video_id="123456789&autoplay=0" width="960" height="541" anchor="my thumbnail image url"]

    Can anyone please help me? I don't want the video to start playing when the page loads, I only want it to start playing when they actually open the modal window that contains it.

    https://wordpress.org/plugins/wp-video-lightbox/

  2. wptipsntricks
    Member
    Plugin Author

    Posted 2 months ago #

    Hi, do you have the "autoplay" option enabled in the video lightbox settings?

  3. iconoclastix
    Member
    Posted 2 months ago #

    Nope, when I go to my Settings > Video Lightbox page and click the "prettyPhoto" tab (since the only option I see under the "General" tab is "Check this option if you want to enable jQuery library")...the "Autoplay" checkbox is unchecked. Any ideas why it's still playing when the page loads?

  4. wptipsntricks
    Member
    Plugin Author

    Posted 2 months ago #

    Can you please provide a link to the page in question so I can take a look?

  5. iconoclastix
    Member
    Posted 2 months ago #

    Sure, here you go: this is the website url

    It's happening right on the main page (the thumbnail image that opens the video modal window is the green square on the right side about halfway down the page (under the full-width video embedded on the homepage directly above it)

  6. wptipsntricks
    Member
    Plugin Author

    Posted 2 months ago #

    Thanks. I don't think it's coming from video lightbox. In fact, the video won't even play until it opens in lightbox (regardless of autoplay).

    I checked the HTML. You have a plugin installed called "easy model" which is printing some vimeo video code. Can you please deactivate it and see how it goes?

  7. iconoclastix
    Member
    Posted 2 months ago #

    Ah, it must have been that plugin...when I disable it, everything works fine. I purchased another modal plugin instead and it appears to be working fine with the video lightbox. Thanks very much for your help! :)

Reply

You must log in to post.

About this Plugin

About this Topic