WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] trying to aim url to subdomain now can't get admin login (9 posts)

  1. ggheart
    Member
    Posted 1 year ago #

    In the attempt to get my url to aim toward a subdomain where I have wordpress installed (and a site built) I changed in I tried advice from this post: Pointing your home site's URL to a subdirectory via this post:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    I added the code and nothing happened so I changed it back to original .htaccess code.

    I then tried changing GENERAL SETTINGS via wordpress address URL to exclude the /subdomain. Things went wrong and so then I believe I changed it back to way it was with the /subdomain and now I cannot access my admin dashboard at all. 404!

    I can see the site by typing in the domain/subdomainfolder, although it stripped off my lovely theme.

    I'm pretty new at all of this.

    Can anyone help me?

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Change the urls back. See Changing_The_Site_URL for details of how to do this.

  3. ggheart
    Member
    Posted 1 year ago #

    that would be good, but I can't login to the dashboard any longer. I won't let me saying

    The requested URL /wp-login.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

  4. ggheart
    Member
    Posted 1 year ago #

    okay, esmi....I put in my thinking mind and used your link and got that to work.
    thank you.!

    So now, how do I easily get the mainsite.com url to aim toward mainsite.com/wp without the subfolder wp showing up?

    thanks

  5. esmi
    Forum Moderator
    Posted 1 year ago #

  6. The instructions on the codex that esmi provided should get you there.
    If you want these explained slightly different, here's a post I did - http://www.bluelimemedia.com/2011/01/31/setting-up-wordpress-for-developmen/

    but essentially, you want to follow the instructions at Giving_WordPress_Its_Own_Directory.

  7. ggheart
    Member
    Posted 1 year ago #

    Okay....here I go giving that a try..!

    If I run into problems I'll be sure to ask again.

    thanks to both of you

  8. ggheart
    Member
    Posted 1 year ago #

    hi there.
    so I got the new site up. the index home page works fine but it can't find the other pages in the main menu.

    how do i fix this?

  9. ggheart
    Member
    Posted 1 year ago #

    Okay, so I can only get the page to show up only if I use the default setting of permalinks. However, is that not the best setting for SEO. Should it not have the post title in the permalink to help with SEO?

    Some advice on this would be appreciated.

    thanks

Topic Closed

This topic has been closed to new replies.

About this Topic