WordPress.org

Ready to get started?Download WordPress

Forums

Trying to add www to first site in MU (5 posts)

  1. cs2870
    Member
    Posted 1 year ago #

    I successfully setup wordpress multiuser, at "mydomain.com"

    I've got a working site there, but wanted to add cloudflare cdn

    when I go to my control panel to enable cloudflare ( through dreamhost control panel ), it says I must add www.

    I have tried to change it by tinkering with settings in wordpress network settings and also by changing the config.php, but haven't a clue what I'm doing honestly, so I set it all back to normal. I just need to know what to do to simply change the first site( and only site ) from being installed as 'mydomain.com' to 'www.mydomain.com'.

    Thanks in advance!

  2. cs2870
    Member
    Posted 1 year ago #

    I forgot to mention, I can add www through my dreamhost control panel, but when I do, the site goes into an endless redirect loop. It looks like it's going from http://www.mydomain to mydomain endlessly, which is why I need to change the way the first site is installed

    Thanks!

  3. Yeah... that's not easy on Multisite.

    I would treat this as a moving Multisite thing: http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Multisite

  4. cs2870
    Member
    Posted 1 year ago #

    How about this, can I just export the current site xml and set it back up, then import the xml file? I don't mind reinstalling it from scratch , i just don't want to lose my posts, etc

  5. If the images aren't available, you'll have to make sure you copy them over manually. It's really not that hard to run the interconnect tool to change the domain name, though, just annoying.

Topic Closed

This topic has been closed to new replies.

About this Topic