WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] trying to add my own image as a banner. (18 posts)

  1. Maxx4444
    Member
    Posted 2 years ago #

    When I try to add my own image header. I keep getting the following.

    Unable to create directory /home/.sites/70/site4/web/blog/wp-content/uploads/2011/08. Is its parent directory writable by the server?

    Why is that?

  2. Probably because you can't write to that directory :)

    Assuming you're using twentyTen or TwentyEleven, they both write the header images to your uploads folder. So go in and make sure the permissions are set correctly. You may need to set them to 755 or 777.

  3. Maxx4444
    Member
    Posted 2 years ago #

    Being new to WP . where do i go to set permission, and thanks for your help.

  4. It's on your server.

    http://codex.wordpress.org/Changing_File_Permissions

    It's a little technical, but it's really not that hard. All you have to do is change the folder permissions via a file manager tool. If you have an FTP app, that's often the easiest.

  5. Maxx4444
    Member
    Posted 2 years ago #

    What file on the server do i edit?

  6. Folder.

    You need to edit the folder /wp-content/uploads/

  7. Maxx4444
    Member
    Posted 2 years ago #

    Is it possible not to have a folder called uploads? lol

  8. Yes :) If it's not there, make it.

  9. Maxx4444
    Member
    Posted 2 years ago #

    so in my wp_content folder. i'll make a uploads folder?

  10. Yes :) and set permissions on that folder to 755

    If that doesn't work, make permissions 777

  11. Maxx4444
    Member
    Posted 2 years ago #

    if the uploads folder is empty. how or where do i set the permission?

  12. Maxx4444
    Member
    Posted 2 years ago #

    Oh yea, I'm on a MAC.

  13. What FTP client are you using? In most of them, you right click on the folder (remember, we're setting the FOLDER permissions, not files, here) on your server and choose 'edit permissions'

  14. Maxx4444
    Member
    Posted 2 years ago #

    I'm using Filezila

  15. Maxx4444
    Member
    Posted 2 years ago #

    I went into filezella and right clicked on the uploads folder, the word permission was not bold, (high lighted)

  16. Read http://codex.wordpress.org/Changing_File_Permissions

    It has examples and screenshots. Every app is a little different so you may need to go for what looks CLOSE to what it is. I don't use Filezilla, though, so I dunno it's interface.

  17. Big Bagel
    Member
    Posted 2 years ago #

    In Filezilla you right-click the file or folder you want to change and click on "File permissions...". The examples in the codex generally use Filezilla, so they should look familiar.

  18. Maxx4444
    Member
    Posted 2 years ago #

    Thanks everyone for the help. i did the permission change on a PC instead of my MAC and it worked. Thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.