WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Troubleshooting WordPress 3.2 - Master List (9 posts)

  1. So OMGWTFBBQ!? WordPress 3.2 broke everything?

    Don't Panic!

    First, upgrade to 3.2.1 (yes, we know). Then remember to be calm, be patient and be respectful. Volunteers are out here to TRY and help you, but we need your help too. ALL forum rules still apply. You are just as important as everyone else.

    • Don't use all caps (in titles or body)
    • Use descriptive subject lines ("All permalinks broken since 3.2" instead of "AUGH! HELP! This version is terrible!")
    • Don't bump your posts (they will be deleted on sight)
    • Make your own topic (it will be easier for us to help YOU that way)

    BEFORE you post:

    Have you tried:

    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don't forget the ones in mu-plugins. If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.2 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

  2. NEW SERVER REQUIREMENTS

    Be aware, WordPress 3.2 has new requirements:

    • PHP version 5.2.4 or greater
    • MySQL version 5.0 or greater

    If you have not yet upgraded and want to make sure you're okay, please use Ryan Duffís WordPress 3.2 Requirementís Check. Should your server not be ready, email your host:

    I run WordPress <http://wordpress.org/> on my website and would like to upgrade to the latest version when itís released. It has the following requirements:

    PHP 5.2.4 or greater

    MySQL 5.0 or greater

    Please make sure that my PHP and MySQL are up-to-date.

    This may be a hassle, depending on how savvy your host is, as there's really no good way to go from SQL 4 to 5 (this is SQL's 'fault'). Both PHP 5 and SQL 5 have been out for years and are stable tech, so if your host WON'T upgrade, look for a new host.

    Errors caused by PHP

    If your THEME or PLUGIN has PHP 4 specific code, things will break. Known issues related to this change:

    Missing class-json.php

    From Dion Hulse

    WordPress 3.2 required PHP 5.2.4 or later, class-json.php was included for compatibility with older versions of PHP only. It was removed here: http://core.trac.wordpress.org/changeset/17603

    Unfortunately, Your theme will need to be updated, you may find that simply commenting out the include line will allow it to continue working if it was using the PHP json functions like any well built theme would have been.

    Alternatively, Copy the json file into your themes folder, and modify the include line to reference the themes folder instead of WordPress's.

    Finally, if you're having UX issues (where you can't drag/drop widgets and similar), and you've already turned off all your plugins and changed to the default theme, you will need to go check if your PHP version has JSON installed. You may be able to add this on via cpanel, or you may have to ask your host to recompile it for you.

  3. NEW ADMIN ISSUES

    Why is WordPress telling me my broswer is outdated/insecure?

    Because it is.

    If you use a non-supported (or very old) browser like IE 6 or 7, or FireFox 3 or 4, WordPress will tell you, in your admin section, that this is out of date and you should upgrade. Yes, this is a nag screen. No, it's not going away. Just upgrade if you can, or click dismiss if you cannot.

    If you're stuck on Windows 98, good news! Opera supported Windows 98 all the way up to 10.63 (released less than a year ago) and that can still be downloaded from http://www.opera.com/browser/download/?os=windows&list=all

    Where did the 'create new post' button go?

    There are "Add New" links everywhere now, next to the screen title, but more importantly, WordPress's direction is to utilize the Admin Bar for these extra links.

    Where did my Network Admin Link Go!?

    It's a dropdown now. Click on 'Howdy, YOURNAME' and it'll show up.

    My site is set to private, but I don't see that in the header anymore.

    That's been removed from the header bar when it was resized. Right now it's only viewable from your site's dashboard, in the 'Right Now' section.

    I don't like how the new admin section looks

    The dashboard's appearance has been redesigned with future versions of WordPress in mind. It can be customized via plugins or CSS.

    See http://codex.wordpress.org/Creating_Admin_Themes

    The Fullscreen button in the Visual editor is now missing!

    To fix the problem:

    1. Deactivate (and preferably remove) the old "WordPress Automatic Upgrade" plugin.
    2. Go to the Dashboard->Updates option in the menu.
    3. On this new page, select to Re-install WordPress 3.2.1. It'll spin a minute and redownload WordPress and install it over itself properly, fixing any missing or broken files.
    4. Clear your browser cache. Your browser will have a copy of the bad Javascript files in memory, and until you clear them out, it won't try to load them from the site again.
    5. Reload the editor page. The full screen button is between the spell check button and the "kitchen sink" button.

  4. TWENTY ELEVEN ISSUES

    If you don't like Twenty Eleven, that's okay, but that's not a bug. Remember you don't have to use it if you don't want to. There are hundreds of FREE themes out there (including Twenty Ten!) in http://wordpress.org/extend/themes - Enjoy!

    There are already plugins that work well with customizing Twenty Eleven past the defaults. Check out http://wordpress.org/extend/plugins/search.php?q=twenty+eleven

  5. PLUGIN ISSUES

    BuddyPress
    http://wordpress.org/extend/plugins/buddypress/

    BuddyPress 1.2.8 has a couple of small issues with WordPress 3.2, mainly with javascript in the BP-Default theme. New version released on July 5th resolves this.

    Facebook Comments for WordPress
    http://wordpress.org/extend/plugins/facebook-comments-for-wordpress/

    Causes "Plugin could not be activated because it triggered a fatal error." on activation. Also seems to cause issues if left on when upgrading.

    WP-Insert
    http://wordpress.org/extend/plugins/wp-insert/

    Causes all the side bars in the admin dashboard to vanish. New version released on July 5th resolves this.

    Tweet This
    http://wordpress.org/extend/plugins/tweet-this/

    Causes a fatal error due to a dependency on the class-json.php file. See Missing class-json.php above.

    To fix the plugin, edit the tweet-this.php file. On line 137, you'll find this code:

    /**
     * JSON functions.
     * @package tweet-this
     * @since 1.7
     */
    if(!class_exists('Services_JSON')) {
    	if(version_compare($GLOBALS['wp_version'], '2.9', '<'))
    		require_once(TT_JSON);
    	else require_once(TT_WP_JSON);}
    if(!function_exists('json_encode')) {
    	function json_encode($data) {
    		$json = new Services_JSON();
    		return($json->encode($data));}}
    if(!function_exists('json_decode')) {
    	function json_decode($data) {
    		$json = new Services_JSON(SERVICES_JSON_LOOSE_TYPE);
    		return($json->decode($data));}}

    Simply remove that section of code entirely and save. Then all is well. That code is no longer necessary with PHP 5, which has the json functions built in.

    Tweet Blender

    Throws JSON errors. The plug-in developer has released a 3.2-compatible version (3.3.10) which fixes the issue: http://bit.ly/pvNPuA

    Headspace2 SEO
    http://wordpress.org/extend/plugins/headspace2/

    Reported to cause menu toggling issues in the Dashboard.

    Block-Spam-By-Math-Reloaded
    http://wordpress.org/extend/plugins/block-spam-by-math-reloaded/

    Reported to interfere with the site administrator's ability to reply to comments.

    List Rank Dashboard Widget
    http://wordpress.org/extend/plugins/list-rank-dashboard-widget/

    Fatal error: Call to undefined function register_setting() in /home/content/k/i/w/kiwivic/html/wp-content/plugins/list-rank-dashboard-widget/wp-list-rank-class.php on line 156.

    JJ NextGen JQuery Slider
    http://wordpress.org/extend/plugins/jj-nextgen-jquery-slider/

    Slider no longer works: images only change on screen refresh, no nav displayed.

    FeedWordPress
    http://wordpress.org/extend/plugins/feedwordpress/

    Causes Fatal error: Call to undefined method WP_SimplePie_File::wp_simplepie_file() in /*/wp-content/plugins/feedwordpress/feedwordpress.php on line 1841

    Fix from ricardofpraimundo:

    Search line 1841
    WP_SimplePie_File::WP_SimplePie_File($url, $timeout, $redirects, $headers, $useragent, $force_fsockopen);

    replace with
    parent::__construct($url, $timeout, $redirects, $headers, $useragent, $force_fsockopen);

    Theme My Login
    http://wordpress.org/extend/plugins/theme-my-login/

    Locks users out of their sites.

    Grooveshark Plugin for WordPress
    Makes it so you can't upload images.

    Digi Traffic Multiplier
    Yet another "left hand menu is missing" problem. The latest version of the plugin should resolve this.

    jQuery Colorbox
    http://wordpress.org/extend/plugins/jquery-colorbox/

    You need to upgrade to the 4.1 version

    jQuery.easein
    Seems to conflict with the new jQuery in WP. No fix at this time.

    Disqus Comment System
    http://wordpress.org/extend/plugins/disqus-comment-system/

    Breaks the jquery interfaces so you can't add images to posts, drag widgets, etc.

  6. THEME ISSUES

    Arras Theme 1.5.0.1 kicks this error:
    Fatal error: Call to undefined method Arras_Widget_Tag_Cloud::WP_Widget_Tag_Cloud() in ..../wp-content/themes/arras/library/widgets.php on line 355

    Read http://www.arrastheme.com/forums/topic6442-15-arras-1501-and-wordpress-32-beta-1.html to fix or upgrade to 1.5.1

    Koi Theme
    Java issues kick user OUT of the post when trying to add a new link. Not all menu items show up in the editor

    Developer says: "You just need to upgrade to the latest zip from our site and clear your browser cache (in case the scripts are cached)."

    http://themify.me/themes/koi

    Beauty & Clean 1.0.2 by Your Inspiration Web
    Makes it so that you can't upload any images.

  7. Dion Hulse
    WordPress Dev
    Posted 2 years ago #

    yourmy: After updating 20 or 30 sites to 3.2, I found out that the submit article body has disappeared, at least in ff and ie - only the title is shown for authors. Please check. Thanks!

    PHP Fatal error: Call to undefined function submit_button()

    This sounds like not all the files were copied over correctly, I'd advice you attempt to perform a manual update as per the instructions in this codex article: http://codex.wordpress.org/Updating_WordPress#Manual_Update - Replace/overwrite the existing files. If you still have access to the Dashboard -> Updates page, you might be able to use the "Reinstall" function there to correct it. If neither of these help, deactivate your plugins, as one of those may be causing the issue.

    reh03jeene: please help me i have this message when i updated my wordpress site
    Warning: require_once(/home/bleys987/public_html/wp-includes/class-json.php) [function.require-once]: failed to open stream: No such file or directory in /home/bleys987/public_html/wp-content/plugins/tweet-this/tweet-this.php on line 145

    The Tweet This plugin you're running is not compatible with the latest version of WordPress. You'll need to delete, or rename, the tweet-this plugin folder via FTP.

    fxmatics: So, why don't our generous WP developers did not warn us about it before we upgrade? :(

    The announcement post mentioned it, and the Automatic update would've prevented you from updating if you did not meet the system requirements. Furthermore, If you managed to update, You would've been locked out of WordPress all together with a system requirements message, not a partially operating WordPress install, Your issue sounds like a Plugin issue overriding the default jQuery that wordPress includes, try disabling your plugins and try again.

    To everyone else: Please make a new thread for your individual issue

  8. IF YOU ARE HAVING JSON ISSUES!

    The new 0.7 version of the hotfix plugin will fix the JSON error some
    people are experiencing with 3.2 until they upgrade to 3.2.1. The hotfix plugin is just a good plugin for everybody to run, in fact.

    http://wordpress.org/extend/plugins/hotfix/

  9. If the TinyMCE fullscreen button is missing, check to see if the site
    is still using the pre-2.7 WordPress Automatic Upgrade plugin.
    Upgrading with that causes an incomplete (but oddly mostly working)
    upgrade.

    To fix the problem:

    1. Deactivate (and preferably remove) that plugin.
    2. Go to the Dashboard->Updates option in the menu.
    3. On this new page, select to Re-install WordPress 3.2.1. It'll spin
    a minute and redownload WordPress and install it over itself properly,
    fixing any missing or broken files.
    4. Clear your browser cache. Your browser will have a copy of the bad
    Javascript files in memory, and until you clear them out, it won't try
    to load them from the site again.
    5. Done. The full screen button is between the spell check button and
    the "kitchen sink" button.

Topic Closed

This topic has been closed to new replies.

About this Topic