WordPress.org

Ready to get started?Download WordPress

Forums

Trouble with the categories and tags (2 posts)

  1. tipejo
    Member
    Posted 6 years ago #

    I updated to wordpress 2.3 and everything seems to be working right, but there is this little problem I have which I don't know if it has something to do with the theme or if it is really a database problem, I just don't know and I hope you can help me out.

    I'm using the theme Road to Heaven in case you need to know. When I try to navigate through the posts, when I do it using the archive ordered in a monthly way I have no problem, everything is working fine. The problem comes when I try to navigate through the posts by categories, the thing that happens is when you choose a category at the end of the site you see the following error message:

    WordPress database error: [Unknown column 'post_id' in 'field list']
    SELECT count(DISTINCT post_id) FROM wp_posts LEFT JOIN wp_term_relationships ON (wp_posts.ID = wp_term_relationships.object_id) LEFT JOIN wp_term_taxonomy ON (wp_term_relationships.term_taxonomy_id = wp_term_taxonomy.term_taxonomy_id) WHERE 1=1 AND wp_term_taxonomy.taxonomy = 'category' AND wp_term_taxonomy.term_id IN ('11') AND post_type = 'post' AND (post_status = 'publish' OR post_status = 'private') ORDER BY post_date DESC

    As it says database error, I don't know if it has something to do with the database or if the error comes from the theme.

    The other thing is, when I try to navigate through the posts using some tag it shows the 5 first posts, but then there is no way to get to the other pages, but I don't get and error message neither.

    To check out both problems take a look at the two links to my web under this lines:

    This one is to see the category problem:
    http://www.slynation.com/category/noticias/

    This one is to see the tag problem:
    http://www.slynation.com/tag/tenerife/

    Thank you for your help.

  2. tipejo
    Member
    Posted 6 years ago #

    Anyone knows how to help, please?? I already checked it out and noticed that it is a theme problem. How can I solve it. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic