WordPress.org

Ready to get started?Download WordPress

Forums

SlickQuiz
trouble with get started button (6 posts)

  1. mjg119
    Member
    Posted 1 year ago #

    Hi I wanted to thank you for taking the time to develop this plugin...it is awesome...

    I have a slight problem...I previously had the plugin working great...I updated to the newest version and now when I visit the page I have quizzes on...the "get started" button is now just text that becomes underlined when I scroll over it...I am thinking it could be a theme related problem...but wanted to ask the master...:0

    If you could help me out it would be tremendous...

    Thanks!

    Mike

    http://wordpress.org/extend/plugins/slickquiz/

  2. mjg119
    Member
    Posted 1 year ago #

    Jewellofthelotus!

    I started digging into the other questions on the support page...and sure enough after some trial and error it was the Footer function.

    It is now fixed...for Cosmox theme...I just cut and pasted the code before the slickquiz shortcode...and boom it worked...

    <body> <!--?php wp_footer(); ?--> </body>
    [slickquiz id=2]

    Thanks again for making this plugin as it is a main feature for my site!

    Mike

  3. magneme
    Member
    Posted 1 year ago #

    I am experiencing the same (?) problem.

    I just updated both the plugin and WordPress (to 3.5). Now, the get started-button just shows up as a text link, which is not working. Also, the text for score and rakning are shown (translated):
    http://oppegard.org/moro/quiz/

    However, everything seems fine in preview-mode.

    I am using a child theme from twentyeleven, and I have checked the footer function which mjg119 mentions above. I have also tried to disable my other plugins.

    Any ideas?

  4. mjg119
    Member
    Posted 1 year ago #

    What I did was...in the html section of the theme where the <slickquiz="1"> shortcode is posted...

    Cut and paste:

    <body> <!--?php wp_footer(); ?--> </body>

    Above the slickquiz shortcode "[slickquiz id=2]"...save and update...that is what worked for me...I didnt modify any css.

    Below is what is posted in the html section on each wordpress page containing the slickquiz shortcode.
    ------------------------------------------------------------------
    <body> <!--?php wp_footer(); ?--> </body>

    [slickquiz id=2]

  5. magneme
    Member
    Posted 1 year ago #

    Hi, mjg119! Thank you for your reply.

    I tried this solution, but it doesn't solve the problem for me. Even if I paste your code above the slickquiz-code, the page still looks the same (the link above contains the page with the code now).

    I suppose you paste the code in the html-mode, not the visual mode? I also noticed the code disappears if I switch back to visual mode. But I guess that doesn't mean anything, as it doesn't seem to work anyway.

    Hope Jewellofthelotus has a solution!

  6. jewlofthelotus
    Member
    Plugin Author

    Posted 1 year ago #

    @mjg119 & @magneme - It does appear that the footer code should solve the problem each of you is having.

    However, the best way to apply the code is by adding it to your theme's footer.php template, rather than everywhere you've including a slickquiz shortcode.

    Instructions:
    Take a look at your theme's footer.php template for the method wp_footer(), if you don't find it there - add the following bit of code to the template before the closing </body> tag:


    <?php
    /* Always have wp_footer() just before the closing </body>
    * tag of your theme, or you will break many plugins, which
    * generally use this hook to reference JavaScript files.
    */

    wp_footer();
    ?>

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.