WordPress.org

Ready to get started?Download WordPress

Forums

WP Facebook Open Graph protocol
Trouble with circular reference (5 posts)

  1. randler
    Member
    Posted 1 year ago #

    Hello!

    I have an issue with canonical url and og:url not being the same.

    Circular reference occurs and when I go to see the source code to look at the canonical url in there it shows this.

    Isn't weird that the canonical url in the sourcecode isn't the same as what the facebook debugger gets.

    The debugger gets this url: http://kurera.develop.infobyte.se/peter-wilhelmsson

    While the canonical url in the source code is:
    <link rel="canonical" href="http://kurera.develop.infobyte.se/peter-wilhelmsson/" />

    How is this possible? And what can I do to make them show the same url? To get rid of the circular reference I need to have the same in both right? So that the og:url doesn't show a different url than the canonical does.

    Here is a picture of how it is now.

    http://wordpress.org/extend/plugins/wp-facebook-open-graph-protocol/

  2. Chuck Reynolds
    Member
    Plugin Author

    Posted 1 year ago #

    well the trailing slash is the issue... this plugin is pulling the server url for the page which yours is returning as no trailing slash whereas whatever you have inputting canonical links is forcing the trailing slash and probably doing the 301 redirect as well.

    IF you have yoast seo on there's an option you may have enabled to force trailing slashes which may be causing this. check on that and make sure that's not set.

    That said... I think we're going to work on implementing this http://kovshenin.com/2012/current-url-in-wordpress/ in the beta that's on github and test that out. Should eliminate the edge-case issues like this.

  3. Chuck Reynolds
    Member
    Plugin Author

    Posted 1 year ago #

    I just updated the dev version on github... if you feel like testing it - http://github.com/chuckreynolds/WPFBOGP
    and you can hit the zip download to get it.

    If you do test it out.. let me know how it went.

  4. randler
    Member
    Posted 1 year ago #

    Hello!

    Now I have tried implementing the new code from the dev version from git. Nothing changed as far as I can see. I am using All in One SEO Pack, is there any settings I should change in there?

  5. Chuck Reynolds
    Member
    Plugin Author

    Posted 1 year ago #

    just pushed another update to the URLs in github.. upon recommendations I also forced trailingslash...

    Let me know.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.