WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] trouble upgrading from 2.5 to 2.5.1 (12 posts)

  1. yllib
    Member
    Posted 6 years ago #

    just upgrade my blog from 2.5 to 2.5.1
    like usual upgrade everything goes smooth, until i try to login

    the login page show like usual, include this on the header

    Warning: Cannot modify header information - headers already sent by (output started at /home/yllib/public_html/blog/wp-config.php:43) in /home/yllib/public_html/blog/wp-login.php on line 202
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/yllib/public_html/blog/wp-config.php:43) in /home/yllib/public_html/blog/wp-login.php on line 214

    when i log-in, it's show this:

    Warning: Cannot modify header information - headers already sent by (output started at /home/yllib/public_html/blog/wp-config.php:43) in /home/yllib/public_html/blog/wp-login.php on line 202
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/yllib/public_html/blog/wp-config.php:43) in /home/yllib/public_html/blog/wp-login.php on line 214
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/yllib/public_html/blog/wp-config.php:43) in /home/yllib/public_html/blog/wp-includes/pluggable.php on line 557
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/yllib/public_html/blog/wp-config.php:43) in /home/yllib/public_html/blog/wp-includes/pluggable.php on line 694

    I already try delete & re-upload the wp-admin & wp-include folder, but it's still the same. Also add the secret_code in wp-config.php, only define the 1 line random code.
    Any suggestion?

  2. whooami
    Member
    Posted 6 years ago #

    yah and you could have found it by searching

    Remove the blank spaces and/or line breaks from the bottom of wp-config.php

    And dont come back and say there arent any. There are. Its not open for debate,

  3. dsather
    Member
    Posted 6 years ago #

    I am having the same problem, and took out anything that looks like it was a line break or space, and I am still having the same problem. And where on this forum is there a search box???? I have looked, but can't see it. No need to get an attitude here. We are new to this forum, and are having problems with this installation, but from what I see there are a LOT of us. I installed an older version of WP a number of years ago, and it seemed to do just fine. I upgraded now, and wish that I hadn't right now. Can someone please explain how to fix this?

    My wp-config file looks like this:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'nkinn_xxxxxx'); // The name of the database
    define('DB_USER', 'nkinn_xxxx'); // Your MySQL username
    define('DB_PASSWORD', 'xxxxxx'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you wont need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    // Change SECRET_KEY to a unique phrase. You wont have to remember it later,
    // so make it long and complicated. You can visit http://api.wordpress.org/secret-key/1.0/
    // to get a secret key generated for you, or just make something up.
    define('SECRET_KEY', 'xxxxxxx'); // Change this to a unique phrase.
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* Thats all, stop editing! Happy blogging. */
    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

  4. dsather
    Member
    Posted 6 years ago #

    Well... I was about ready to tear my hair out with this one. I finally went back to Fantastico and did an install with that instead of manual install... I wanted to get the most up to date version, so I went with the manual install first. I had fantastico install, but I was still getting the same errors. Then I went to another template, and lo and behold... No more errors!!!! It must be something in that particular template that was not compatible with this version of Word Press. Now it works like a charm.

  5. yorokobi
    Member
    Posted 6 years ago #

    Well then I guess it IS up for debate eh?

    So it was a matter of the template being incompatible - good to keep in mind - I too had that happen when 2.5 first came out, but that template was practically a program of it's own - very complex.

  6. whooami
    Member
    Posted 6 years ago #

    templates (themes) have nothing to do with the error the OP pasted.

    If simply replacing your theme fixed an error, it was a similar error, NOT the exact error. "Headers sent by.." errors occur frequently; the OP's is the most common.

    spaces or linebreaks before the opening <?php cause :

    Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/blog/wp-config.php:1) in ...

    spaces or linebreaks after the closing ?> cause what the OP pasted, an error that seemingly is in in invisible last line of the file.

    Both are introduced by editing wp-config.php in an icky editor.

  7. yorokobi
    Member
    Posted 6 years ago #

    Actually, I did a clean install last night and after going though the script to generator a config.php the admin backend came up as an empty page. I checked the config.php directly via FTP and it had a white space after the ?> and an extra carrage return too.

    I don't exclude that it's the fault of my ISPs server tho.

  8. whooami
    Member
    Posted 6 years ago #

    You, or your host have error reporting turned off in PHP. If you had them on, you would have seen the error.

    Silent errors in PHP cause blank pages. Thats why those of us that have been answering the same "my page is blank" questions for three years tell people to disable plugins, and then switch to the default theme.

    There is a reason for the things that get repeated over and over and over again on here.

    --

    Good for you for having the wherewithall to actually look for yourself. :)

  9. yorokobi
    Member
    Posted 6 years ago #

    Thanks. I'm still hunting for what makes it think it's still 2.5 when it's 2.5.1

    So far the only (unacceptable) thing that I've done that worked is export - reinstall making a blank database - then import.

    I could load a backup, as I use a plugin that auto-dumps and email the database every week, but this seems to be related to the site being hacked (I think they are calling it the wp-info hack?) and I don't know when the corruption occured.

    I deleted and reinstalled all but wp-content and I scoured that manually so the "NEW" files are gone. I deleted the phantom users from the database. So I think the hacks are gone, but I still get the "update nag"

    Back to hunting...

  10. yllib
    Member
    Posted 6 years ago #

    ok solved. i'm too panic so im not search 1st :p actually this is the 1st time having problem hehe... thanks all

  11. yorokobi
    Member
    Posted 6 years ago #

    FOUND: There were 2 hacked entries for the plugins in the data base (Activated plugins had a "phantom" entry and there was a Deactivated Plugins entry which I think doesn't belong there at all), which I deleted via phpMyAdmin and a hack file (Screenshot_old.jpgg) in my active theme's directory.

  12. Olllive
    Member
    Posted 5 years ago #

    WHOOAMI
    This is an old topic, but your old answer resolved my current problem.
    You. are. a. GENIUS.
    haha Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags