WordPress.org

Ready to get started?Download WordPress

Forums

Simplr Registration Form Plus+
Trouble getting Moderation to work (28 posts)

  1. hbuchel
    Member
    Posted 1 year ago #

    I am having trouble getting the moderation feature for Simplr Registration Form Plus+ to work. I have "Enable Moderation" set to "Yes" and approval mode set to "Manual", yet when a user fills out the registration form I created, they are automatically assigned to a role (in this case subscriber) instead of me having to manually approve them. Is there something I am missing, or does this not actually work how I'm thinking it does? I assumed moderation meant the user would receive an e-mail with the moderation message, and a site admin would have to manually adjust their role in the WordPress admin.

    http://wordpress.org/extend/plugins/simplr-registration-form/

  2. broganm
    Member
    Posted 1 year ago #

    I have the same problem. I want the Admin to be able review and activate the account before the user gets anything.

  3. trekkerd
    Member
    Posted 1 year ago #

    Me three.

  4. trekkerd
    Member
    Posted 1 year ago #

    Did either of you find a fix for this? I have not. Thanks.

  5. mpvanwinkle77
    Member
    Plugin Author

    Posted 1 year ago #

    Hey guys, sorry for the delay on this. I've been slammed at work. Looking into this now.

  6. mpvanwinkle77
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, moderation is broken, working on a fix today and tomorrow, should have it out by wednesday.

  7. Ebo1233
    Member
    Posted 1 year ago #

    Glad to see its not something I was doing...
    I was just about to post to say I was having the same problem as the above when I noticed the Plugin Author had already commented.

    So instead I will say it's a very nice plugin mpvanwinkle77 and I look forward to the fix.

  8. mpvanwinkle77
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, just pushed out the moderation fix. Please give it a try.

  9. Ebo1233
    Member
    Posted 1 year ago #

    Hi Mike,

    Thanks for pushing out the moderation fix as promised. It seems to be working well on my system.

    I was wondering if there is anyway that there could be a message on the form page just in case a user decides to try to login without having been authorised yet.
    Perhaps something like 'Your account is yet to be authorised. Please wait until your authorisation email is sent to you from our administrator..'
    It's just an idea.

    Thanks again for the fix.

  10. mpvanwinkle77
    Member
    Plugin Author

    Posted 1 year ago #

    Good idea, I'll make that editable on the next version.

  11. Ebo1233
    Member
    Posted 1 year ago #

    Great!
    Glad to hear the suggestion was useful:-)

  12. Yasp0
    Member
    Posted 1 year ago #

    That's a good suggestion Ebo1233.

    Now when a non-authorised wants to login there is a default empty red error box.

  13. mpvanwinkle77
    Member
    Plugin Author

    Posted 1 year ago #

    Can you take a screenshot of the "empty" error box. There should be a message there.

  14. Yasp0
    Member
    Posted 1 year ago #

    When I disable the plugin and try to login with wrong password I also get an empty red error box. So I think it's my WP installation...

  15. spaceme
    Member
    Posted 1 year ago #

    Hi,

    I really appreciate for developing this extremely useful and such a easy to use plug-in. I was able to integrate most of the features within couple of hours end-to-end. Now i've the registration page with all the fields up and running.

    But the moderation is still seem to be broken. I've tested it. It doesn't ask the admin for moderation. It creates the new user without moderation. Can you please help?

    I'm using Simplr User Registration Form Plus version 2.2.3.

    Really appreciate your help

    Thanks !!

  16. detoner
    Member
    Posted 1 year ago #

    I also have problems with the moderation - it is assigning the user role without asking for approval from an admin!!

    but the new user cannot login and an admin has no way of approving the new user!!.

    Using the latest version of the plugin

  17. mpvanwinkle77
    Member
    Plugin Author

    Posted 1 year ago #

    @Spaceme and @detoner I will look into this today.

  18. imfromio
    Member
    Posted 1 year ago #

    Just wanted to chime in and say I'm looking for this solution as well. Like the others, I am using version 2.2.3 and have turned on moderation and set it to manual. New users receive their registration emails immediately after registering.

    I don't know if this makes a difference, but I am using this plugin on a multisite. Everything else works well excerpt for moderation.

    Thanks!

  19. TLLitherland
    Member
    Posted 1 year ago #

    Me too!.
    Moderation enabled.
    Admin receives standard WP email showing a new user has registered, but I have no way to moderate the account to approve it. The Activate check box or something is missing.

    User appears to be assigned to Subscriber, which is correct, and they show in the Users admin section, yet they are not able to login, though they do receive the "Your account needs to be activated by an admin" notice appearing upon attempt.

    Thank you for looking into this :)

    PS. Is there a way to integrate the WP User fields into the standard form instead of adding new fields for these. Solely because it now appears 2x in the User section because my client wants to have the Website, Facebook, Twitter and Google page elements filled in on Registration, and these are now built-in to WP. ?? Just a suggestion to make available. I believe Profile Builder has similar feature...

  20. spaceme
    Member
    Posted 1 year ago #

    @mpvanwinkle77

    Thank you for taking time to respond to the queries/clarifications. I really appreciate your time and effort.

    I have these issues to report and not sure if others are having the same issues though.

    1) The moderation works - Admin can approve new users post-registration.
    2) But, the configured customized email doesn't go to the user after successful registration.

    @detoner , @TLLitherland and @imfromio

    There are couple of things i believe the plug-in automatically does -

    1) Assigning "Subscriber" role for the new user. I believe this is done because this is the least privileged role in WP. I think this is a better behavior than assigning some random role. Agree?

    2) Whenever a new user is created, you can see them under "Users > Inactive Users" in WP admin. Admin can activate or delete and can do whole bunch of other operations on this new user.

    3) New user cannot login, until Admin takes a definitive action. After all why do you need moderation, if you let the user login?

    Hope this helps.

    @TLLitherland

    I did try "Profile Builder" plug-in too. Except those sociable fields, in terms of other fields, this plug-in does a good job. May be Profile Builder Pro has better flexibility, not sure.

    Is there a way to integrate the WP User fields into the standard form instead of adding new fields for these.

    I think this is good because, the users won't see new form elements on their WP user profile upon login. This behavior goes well with my thinking. But may be not for others.

    Thanks,

  21. mpvanwinkle77
    Member
    Plugin Author

    Posted 1 year ago #

    @TLLitherland ... Hi you should see an "inactive users" link in your user management screen. That is where you moderate the users. Are you not seeing this screen at all?

  22. TLLitherland
    Member
    Posted 1 year ago #

    Thanks @spaceme for you updates and advice.

    When I activate the Moderation the 'Inactive Users' area does not appear for me in the menu options and the Activate/deactivate option does not appear below the user either. This is also the case with or without other plugins active, and the theme set to Twenty twelve, so I know it is not a compatibility issue.

    In the interim I have installed a separate moderation component to allow for this to work.

    I definitely believe in incorporating what is already available with User Field Meta data in the Profile section rather than having to re-create these for the registration field. Being able to tick them on and off in for the Reg. form would prove very valuable and easy to use.

    My client is also asking for the Admin email to contain all the data provided in the Form to be emailed to them upon registration (as the Admin). I.e. The Admin receives an email containing all information from all fields, inclusive of the User Meta Data fields. Can this be achieved? I've looked at creating my own plugin for this but fail to find a means to include the User Meta Fields in the New Registration Email to the Admin. Perhaps you can help with this.

    Thanks for all the effort and help. Great plugin and will be even greater with a little more tweaking. :)

  23. aoverton
    Member
    Posted 1 year ago #

    I'm seeing users in the the Inactive Users section but I see no way to active the user. I also never received the email alerting me to the new user signup even though I have the email set in the notify attribute for the shortcode.

  24. mpvanwinkle77
    Member
    Plugin Author

    Posted 1 year ago #

    To activate the user check the box next to the user and select "Activate User" from the bulk actions dropdown list.

  25. aoverton
    Member
    Posted 1 year ago #

    Wow, I don't know why but I completely overlooked that first dropdown and went straight to change role. Thank you!

  26. chinchu
    Member
    Posted 1 year ago #

    Hi
    I am trying to activate the inactive users. Thank you very much for your answer.:)

  27. indaloweb
    Member
    Posted 1 year ago #

    Hello Mike, The moderation option doesnt work for me, I select manual but it works like automatic.
    Thanks for your plugin, if it works it will be great.

    Best regards,
    Alex

  28. curiouslt
    Member
    Posted 10 months ago #

    I can't get the moderation to work either, it's just approving everyone. I don't have an inactive users section. Anyone resolve this?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.