WordPress.org

Ready to get started?Download WordPress

Forums

Trouble establishing GoDaddy/Starfield Database (3 posts)

  1. Itztommy80
    Member
    Posted 2 years ago #

    Has anybody else run into issues with setting up?

    Database name should be "hostedresource", right?

    Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the "my database" database.

    Are you sure it exists?
    Does the user "my user" have permission to use the "My Database" database?
    On some systems the name of your database is prefixed with your username, so it would be like username

  2. Go Daddy
    Go Daddy Support
    Posted 2 years ago #

    Your database name will most likely contain "hostedresource" but that won't be the complete name.

    It should look something like: xxxxxxx.db.#######.hostedresource.com

    This article should help you with finding out the actual name and getting your database set up correctly: http://go.me/VN

  3. RichardWPG
    Member
    Posted 2 years ago #

    - First, try contacting the hosting provider if the database server is online / if they have any other problem at their end, or they made any changes to your account, or if there are any limitations/restrictions, if the hosting package is set to Windows and not Linux, etc .

    - double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    -Then check that you don't need to change the database host from "localhost" to something else. You can get that info from your hosting provider.

    -Check you have actually created a database with the same database name as is in your wp-config.php file.
    -Last, but not least, if all that information is correct your database probably has a problem with it, and you may need to contact your hosting provider.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags