WordPress.org

Ready to get started?Download WordPress

Forums

Trouble Converting to 2.1 (8 posts)

  1. timkbrown
    Member
    Posted 7 years ago #

    I attempted to move from 2.07 to 2.1 and have run into major problems. I first attempted the one click upgrade path via my host but I kept getting an error message via email saying my directories weren’t empty. Sure enough they weren’t but there were never any instructions to empty them in the first place.

    As a newbie, I took the higher risk approach of following the instructions under Upgrading WordPress.

    I’ve obviously done something horribly wrong because now when I load my blog’s home page I get the following php error:

    Fatal error: Cannot redeclare timer_stop() (previously declared in /home/.lint/timkbrown/timkbrown.com/wp-settings.php:65) in /home/.lint/timkbrown/timkbrown.com/wp-includes/functions.php on line 865

    With all my playing around, my blog is gone but I’m desperately hoping it can be recovered. With the deep mess I’ve dug myself, is there any way I can do a fresh new install of 2.1 and somehow recover my posts and comments etc.?

    Any help desperately appreciated.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Given that particular error message, I don't believe you have uploaded all of the files from 2.1 to your blog. The wp-includes/functions.php in 2.1 does not declare timer_stop at that location. So clearly, you have not upgraded that particular file.

    Might want to make sure that you uploaded *all* the 2.1 files correctly.

  3. timkbrown
    Member
    Posted 7 years ago #

    Otto42,

    I'm back in business (almost) thanks to your help. (I misunderstood and thought only files, not folders got moved over with the upgrade). My remaining issue is that the archive seems to be corrupted. Where the archive use to appear I now get:

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1]
    SELECT cat_id, cat_name FROM

    Are you able to help with this issue?

    Thanks you very much!

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Yes, the categories changed a lot with 2.1, and so the code causing that is probably in your theme. Try to find an update for your theme, to make it 2.1 compatible there.

  5. timkbrown
    Member
    Posted 7 years ago #

    I stand corrected... The archives appear to be okay, but the database error remains and is displayed here.

  6. timkbrown
    Member
    Posted 7 years ago #

    Thank you Otto42. Very much appreciated.

  7. jake359
    Member
    Posted 7 years ago #

    I also am receiving fatal errors after trying to upgrade to 2.1 (from 2.0). Deleted/reinstalled twice. Still doesn't work. Muy malo.

  8. jake359
    Member
    Posted 7 years ago #

    After deleting everything, reinstalling, and choosing "Upgrade", it works :)

Topic Closed

This topic has been closed to new replies.

About this Topic