WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Trouble connecting to mysql server (8 posts)

  1. BFarthing
    Member
    Posted 1 year ago #

    I keep running into this error message when I test the connection:

    DATABASE CONNECTION FAILED! Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

    Is this a local issue, or do I need to find out the socket info of my host?

    http://wordpress.org/extend/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey BFarthing,

    If you on a hosted server I would contact them. There can be several different issues with that error. Goggling: Can't connect to local MySQL server through socket '/tmp/mysql.sock' will also provide several different possible solutions...

    Hope that helps!

  3. BFarthing
    Member
    Posted 1 year ago #

    The tech support guy said it was a local issue. Do I need mysql installed on my computer to use Duplicator?

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Yes you'll need PHP, Apache and MySQL. You can use a tool like XAMPP or MAMPP which provide this all in one bundle...

  5. BFarthing
    Member
    Posted 1 year ago #

    I'm on a hosted server. I don't run anything from my home machine. I'm looking at different solutions on google, but I'm not sure whether I should be doing these things on my hard drive or on the server where my website is hosted.

  6. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Whatever server you use it will have to have all 3 apps. If the host tech said it was a local issue what exactly is he talking about? They should be a bit better at helping you troubleshoot the issue if your paying for them to host your site...

    Did you search your hosts forums/help for others who have had the same issue?

  7. BFarthing
    Member
    Posted 1 year ago #

    Yeah, they should be. Unfortunately, they're a jack-of-all trades cable provider, and the person I'm doing the site for won't change.

    Turns out they'd given me the wrong host name. Once I got that right I was able to go through the install process.

    I have more issues, but they're different so I'll start a different thread.

    Thanks for the help, lifeinthegrid.

  8. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds good! I'll check out your other items...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.