WordPress.org

Ready to get started?Download WordPress

Forums

Trouble Accessing Site on Phone and Different Browsers (10 posts)

  1. eaventures
    Member
    Posted 3 months ago #

    Hello,

    I created a site rogeranthonyart.com, hosted on godaddy, and I'm having the hardest time pulling it up on browsers outside of my cached Firefox one. Most browsers (phone, IE, Chrome, Safari) direct the site to the godaddy host page:

    https://www.dropbox.com/s/p4kqeqjbx6i8rlx/Screen%20Shot%202014-05-06%20at%208.43.43%20PM.png?m= (browsers)
    https://www.dropbox.com/s/54k34bcvr69uhdo/image%281%29.png (mobile)

    Could you please help? Not sure what to do at this point, Godaddy says that it deals with the htaccess file (which they do not provide support for) and advised me to consult with you.

    Please let me know if you can provide any assistance, I can provide FTP login info, if needed.

  2. Bryan Purcell
    Member
    Posted 3 months ago #

    can you paste the htaccess file into the forums? (in backticks preferably)

  3. eaventures
    Member
    Posted 3 months ago #

    not sure what backticks mean, can I send and upload in zipfile:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # BEGIN wtwp_cache
    <IfModule mod_mime.c>

    # Text
    AddType text/css .css
    AddType application/x-javascript .js
    AddType text/html .html .htm
    AddType text/richtext .rtf .rtx
    AddType text/plain .txt
    AddType text/xml .xml

    # Image
    AddType image/gif .gif
    AddType image/x-icon .ico
    AddType image/jpeg .jpg .jpeg .jpe
    AddType image/png .png
    AddType image/svg+xml .svg .svgz

    # Video
    AddType video/asf .asf .asx .wax .wmv .wmx
    AddType video/avi .avi
    AddType video/quicktime .mov .qt
    AddType video/mp4 .mp4 .m4v
    AddType video/mpeg .mpeg .mpg .mpe

    # PDF
    AddType application/pdf .pdf

    # Flash
    AddType application/x-shockwave-flash .swf

    # Font
    AddType application/x-font-ttf .ttf .ttc
    AddType application/vnd.ms-fontobject .eot
    AddType application/x-font-otf .otf

    # Audio
    AddType audio/mpeg .mp3 .m4a
    AddType audio/ogg .ogg
    AddType audio/wav .wav
    AddType audio/wma .wma

    # Zip/Tar
    AddType application/x-tar .tar
    AddType application/x-gzip .gz .gzip
    AddType application/zip .zip
    </IfModule>

    <IfModule mod_expires.c>
    ExpiresActive On

    # Text
    ExpiresByType text/css A31536000
    ExpiresByType application/x-javascript A31536000
    ExpiresByType text/html A3600
    ExpiresByType text/richtext A3600
    ExpiresByType text/plain A3600
    ExpiresByType text/xml A3600

    # Image
    ExpiresByType image/gif A31536000
    ExpiresByType image/x-icon A31536000
    ExpiresByType image/jpeg A31536000
    ExpiresByType image/png A31536000
    ExpiresByType image/svg+xml A31536000

    # Video
    ExpiresByType video/asf A31536000
    ExpiresByType video/avi A31536000
    ExpiresByType video/quicktime A31536000
    ExpiresByType video/mp4 A31536000
    ExpiresByType video/mpeg A31536000

    # PDF
    ExpiresByType application/pdf A31536000

    # Flash
    ExpiresByType application/x-shockwave-flash A31536000

    # Font
    ExpiresByType application/x-font-ttf A31536000
    ExpiresByType application/vnd.ms-fontobject A31536000
    ExpiresByType application/x-font-otf A31536000

    # Audio
    ExpiresByType audio/mpeg A31536000
    ExpiresByType audio/ogg A31536000
    ExpiresByType audio/wav A31536000
    ExpiresByType audio/wma A31536000

    # Zip/Tar
    ExpiresByType application/x-tar A31536000
    ExpiresByType application/x-gzip A31536000
    ExpiresByType application/zip A31536000
    </IfModule>
    <FilesMatch "\.(?i:css|js|htm|html|rtf|rtx|txt|xml|gif|ico|jpg|jpeg|jpe|png|svg|svgz|asf|asx|wax|wmv|wmx|avi|mov|qt|mp4|m4v|mpeg|mpg|mpe|pdf|swf|ttf|ttc|eot|otf|mp3|m4a|ogg|wav|wma|tar|gz|gzip|zip)$">
    <IfModule mod_headers.c>
    Header set Pragma "public"
    Header append Cache-Control "public, must-revalidate, proxy-revalidate"
    Header unset ETag
    </IfModule>
    </FilesMatch>
    <FilesMatch "\.(?i:css|js|gif|ico|jpg|jpeg|jpe|png|pdf|swf|ttf|ttc|eot|otf)$">
    <IfModule mod_headers.c>
    Header unset Set-Cookie
    </IfModule>
    </FilesMatch>
    # END wtwp_cache

    # BEGIN wtwp_security
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /roger/
    RewriteRule ^wp-admin/includes/ - [F,L]
    RewriteRule !^wp-includes/ - [S=3]
    RewriteRule ^wp-includes/[^/]+\.php$ - [F,L]
    RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F,L]
    RewriteRule ^wp-includes/theme-compat/ - [F,L]
    </IfModule>
    <Files "wp-config.php">
    Order allow,deny
    Deny from all
    </Files>
    Options -Indexes
    # END wtwp_security

  4. Bryan Purcell
    Member
    Posted 3 months ago #

    Ok - so the first thing you want to do is disable the caching software that's generating this htaccess stuff - I think it's causing problems. What caching plugins are you using on your site?

  5. eaventures
    Member
    Posted 3 months ago #

    I spoke to the designer of the theme, they stated that there is no caching software applied to this and need to contact my hosting provider.

    My question to you is what specifically do I ask GoDaddy because I've been going back and forth with them about this for the past couple of weeks.

  6. Bryan Purcell
    Member
    Posted 3 months ago #

    The first thing i'd recommend is to back up the htaccess file, then delete it from your root directory. If the problem is, in fact, your ht access file this will allow you to get to the /wp-admin dashboard. If you can get there, go to Settings -> Permalinks, and click save on your desired setting.

  7. eaventures
    Member
    Posted 3 months ago #

    Ok not sure what this actually means or how to approach this. Are you saying that I need to delete the htaccess file?

    Can I just rename it to something else? Also, what I am I adjusting in the Permalinks setting and will this solve the problem?

  8. Bryan Purcell
    Member
    Posted 3 months ago #

    Yes - that will work. Rename it, then go the Settings -> Permalinks and change the setting to "Default." Check the frontend of the site, and see if you're able to load the site. If so, set up the permalinks according to your preferences.

  9. eaventures
    Member
    Posted 3 months ago #

    Awesome! I think it works now!

  10. eaventures
    Member
    Posted 3 months ago #

    So apparently is does no work... changing the settings -> permalinks created a new htaccess file and it worked on my computer, but when I log to other computers, it takes me here : http://rogeranthonyart.com/?reqp=1&reqr=

    Please assist.

    [Please don't bump]

Reply

You must log in to post.

About this Topic