WordPress.org

Ready to get started?Download WordPress

Forums

Tried to make my site live removing /wp in url and lost access to dashboard (26 posts)

  1. gite_kaus
    Member
    Posted 11 months ago #

    Hi guys!

    http://www.propertypeaks.co.uk
    I've tried to make my site live by removing /wp in url and lost access to dashboard! It gives me - 404 Not Found message! No dasboard no website! I've tried many things - nothing is working :(
    Please please help!

  2. Krishna
    Volunteer Moderator
    Posted 11 months ago #

    Change it back. Then review the following link and change the URL as explained. If you still face problems, come back and report here.
    http://codex.wordpress.org/Changing_The_Site_URL

  3. gite_kaus
    Member
    Posted 11 months ago #

    SORRY,im not really sure what change it back? Do i start from the beginning in wordpress and import the .xml file(my site, which i exported from dasboard)?

  4. Krishna
    Volunteer Moderator
    Posted 11 months ago #

    I've tried to make my site live by removing /wp

    Only this. Put back to what it was.

  5. gite_kaus
    Member
    Posted 11 months ago #

    Im not sure how, as i can't access my dashboard

  6. Krishna
    Volunteer Moderator
    Posted 11 months ago #

    Try this method:
    http://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

    Please backup your site first, including database, so that you can always restore what you have now in your site.

  7. gite_kaus
    Member
    Posted 11 months ago #

    I did follow the steps, but the right name was already there- http://www.propertypeaks.co.uk/blog. Did i have to remove "/blog"from URL?

    I still get the message when i try to access dashboard:
    Not Found

    The requested URL /blog/wp-login.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

  8. Krishna
    Volunteer Moderator
    Posted 11 months ago #

  9. gite_kaus
    Member
    Posted 11 months ago #

    I've tried that many times. Here is another try, and the message i get is:

    Not Found

    The requested URL /blog/wp-login.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

  10. billius
    Member
    Posted 11 months ago #

    Hi Also new to forum, spotted your question. I did what sounds like the same thing yesterday - to resolve I had to edit the functions.php file in my cpanel themes folder, then remove the edit when I got back into wordpress. Not sure if you have the same issue or not. Hope this helps.

  11. gite_kaus
    Member
    Posted 11 months ago #

    Hi thanks for your respond. I can't get to wordpress. What exactly you changed in functions.php?
    Thanks

  12. billius
    Member
    Posted 11 months ago #

    Try this.

    http://codex.wordpress.org/Changing_The_Site_URL

    As I said I had to do this via my webhosters cpanel and look for my current theme, this probably only applies if this is how you have wordpress set up like this. I guess you do if you have a /wp url.

    You are basically setting it back to the pre-changed values.

    Note I hadn't touched the SQL DB

    Good luck.

  13. gite_kaus
    Member
    Posted 11 months ago #

    i've tried that one as well, but nothing works! :(
    i get login page, but after i press login, it shows:

    Not Found

    The requested URL /blog/wp-login.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Im giving up slowly, i think i just have to redo everything! :(

  14. gite_kaus
    Member
    Posted 11 months ago #

    I recreated all my website! I don't want to mess up again trying to make it live. I did follow directions, but by removing /wp at the end of my url link prohibited me from accessing dashboard on wp and making my website live!
    Can someone help with what is the correct way to make my website live!
    My url now is http://www.propertypeaks.co.uk/wp
    Thank you!

  15. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    i've tried that one as well, but nothing works!

    Which of the four methods outlined in Changing_The_Site_URL did you try? I have used the function.php method many times without the slightest problem.

  16. gite_kaus
    Member
    Posted 11 months ago #

    Thanks for your reply. Did u just do function.php bit or you removed /wp in general settings as well?
    Did you copied index page to root folder as well in cpanel?
    Maybe i did too many things then and thats why it didnt work, hmm?
    And did you get access to worpress dashboard afterwards?

  17. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    You can just use functions.php to change your site's url. I would suggest that you use just this method to revert the site's url back to http://www.propertypeaks.co.uk/wp

    Then, once the site is working back at its old url again, see Giving WordPress Its Own Directory.

  18. gite_kaus
    Member
    Posted 11 months ago #

    Sorry, im confused. So i need to use function.php to get http://www.propertypeaks.co.uk
    And in oreder to access http://www.propertypeaks.co.uk/wp i need to do Giving Word .... Is that right?
    Im just extra carefull as i already had to recreate the site.

  19. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

    No - use functions.php to reset the site's urls back to http://www.propertypeaks.co.uk/wp

    Once the site is working again at its old url, see Giving WordPress Its Own Directory.

  20. gite_kaus
    Member
    Posted 11 months ago #

    i did recreate my website already as none of the suggestions worked.
    So now i need to use Giving ...directions in order to remove /wp from my url?

  21. gite_kaus
    Member
    Posted 11 months ago #

    Ok, just did that! I was able to log back in to http://www.propertypeaks.co.uk/wp/wp-admin.php
    but when i went to http://www.propertypeaks.co.uk, it didn't connect me and said :TIMED OUT! in the url instead of http://www.propertypeaks.co.uk it was http://mail.propertypeaks.co.uk/

    Hrrr, not sure what's happening! Please help!

  22. esmi
    Theme Diva & Forum Moderator
    Posted 11 months ago #

  23. gite_kaus
    Member
    Posted 11 months ago #

    Dashboard is opening, but my Website http://www.propertypeaks.co.uk gives me a message:

    Fatal error: require(): Failed opening required './wordpress/wp-blog-header.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/propert1/public_html/index.php on line 17

    How can i solve this please?

  24. gite_kaus
    Member
    Posted 11 months ago #

    Figured it out!!!!!!!!!! Anyway, thank you Krishna and Esmi for all your support and patience! :)

  25. mk5103
    Member
    Posted 4 months ago #

    Can you please let me know what the error was. I am facing the same problem. And I am in urgent need to get this error fixed. Thanks.

  26. WPyogi
    Volunteer Moderator
    Posted 4 months ago #

    @mk5103 - please start your own thread if you need help - read the forum welcome first so you know what to include in your post -

    http://codex.wordpress.org/Forum_Welcome

Reply

You must log in to post.

About this Topic