WordPress.org

Ready to get started?Download WordPress

Forums

Tried to change URL of blog in "Options," didn't work, now can't change back (9 posts)

  1. dibs
    Member
    Posted 7 years ago #

    Help! I installed WordPress successfully at my domain, but the URL of the blog was coming up as "www.myblog.com/wordpress". I wanted it, of course, to be simply "www.myblog.com". (Throughout this question, I use the generic name "myblog" instead of my real blog name. "myblog" is not the actual name of my blog, so ignore the automatically generated links throughout the question.) So I went to the "Options" section of the Dashboard, and followed the instructions to change the address of the blog itself where it says, "If you want your blog homepage to be different than the directory you installed WordPress in, enter that address here." I entered http://www.myblog.com. Then I hit the "Update Options" button.

    Big mistake!

    Now everything is screwed up at the blog site, and the key is that WordPress has made it impossible for me to change any more Options. I'll try to explain.

    When I now go to http://www.myblog.com, the rudimentary text of the blog is on the page, but there are no graphics, and no layout. I.e. it is not properly accessing any theme. If I try to go to "Site admin", the link takes me to http://www.myblog.com/wp-admin/, which doesn't exist, and I get a 404 error. But if I manually add in the wordpress directory to the URL, i.e. go to http://www.myblog.com/wordpress/wp-admin/, I get to the Admin page, but it's a strange version of the Admin page, again lacking all graphics and layout, and only having text.

    And here's the problem: when I try to do anything on this Admin/Dashboard page, and click any button at the bottom that sends the instructions and make the action supposed to happen, I go to a page with this message every time:

    Sorry, you need to enable sending referrers for this feature to work.

    The problem is that the Admin/Dashboard page sends the update instructions to http://www.myblog.com/whatever (which doesn't work), instead of to http://www.myblog.com/wordpress/whatever.

    Why? Because, as I see on the Options page, it now lists

    WordPress address (URI):

    as being at http://www.myblog.com, instead of being at http://www.myblog.com/wordpress.

    So, you might think -- the solution is so easy! Just change the "WordPress address (URI):" to be correct again, i.e. change it to "www.myblog.com/wordpress".

    But that's what's driving me crazy -- I can't! Whenever I make a change on that Options page -- even that change -- I click the "Update Options" button and get the error message "Sorry, you need to enable sending referrers for this feature to work."

    So -- how can I get back to where I started? Or fix the problem?

    I have tried every imaginable fix attempt as described by the WordPress help pages, but none of them worked. I followed the instructions on the "Enable_Sending_Referrers" page, but that didn't work and seemed irrelevant anyway; my referrers already are enabled.

    I also CAREFULLY followed ALL the instructions on the "Giving_WordPress_Its_Own_Directory" page, but agonizingly that didn't work either.

    Help! I know there is a very simple fix for this, but it eludes me. All I want is to change the "WordPress address (URI):" in the "Options" page to be correct. I'm sure once that happens, the problem will be fixed. But I've been trying to figure out how to effect this change manually, since I can't do it on the Web-interface Options page any more. But My attempts have not worked.

    Any suggestions would be greatly appreciated on this. Thanks.

  2. BPartch
    Member
    Posted 7 years ago #

    Move all the files and folders out of the /wordpress/ folder and up one level to the root of your server.

  3. dibs
    Member
    Posted 7 years ago #

    Move all the files and folders out of the /wordpress/ folder and up one level to the root of your server.

    How?

  4. BPartch
    Member
    Posted 7 years ago #

    I would use whatever FTP program you use, go into the /wordpress/ folder highlight all the files and folders, then drag them up to the go up one level button, icon.

  5. dibs
    Member
    Posted 7 years ago #

    Move all the files and folders out of the /wordpress/ folder and up one level to the root of your server.

    Ah, ignore my "How?" question -- I figured it out. I moved the files and folders up one level, and solved the immediate problem. Thank you!

    However, I still have the other major problem -- all the graphics and layout still don't appear, either in the Dashboard or the blog itself. Only text. The functions all now work (I can change the Options at last), but some little detail has gone awry concerning some file that controls the "look" of the pages. Any suggestions?

  6. Chris_K
    Member
    Posted 7 years ago #

    The other option, if you have phpMyAdmin, would be to move it back to where it was and follow this tutorial: http://www.tamba2.org.uk/wordpress/site-url/

  7. dibs
    Member
    Posted 7 years ago #

    Here's what I'm talking about:

    You know how your own Dashboard is supposed to look? With a certain amount of graphics and layout, etc.? Well, I took a screenshot of how my Dashboard looks, to show you how it is nothing but text. Here's the link to the screenshot:

    http://www.dibsblog.com/screenshot.jpeg

    How can I fix this?

  8. dibs
    Member
    Posted 7 years ago #

    Hmmm, mysteriously, my final problem has fixed itself! Not sure how I did it, but now, after about half an hour, the Dashboard suddenly has all its graphics back, as does my blog. And I don't remember doing anything to cause this to happen! Strange.

    Anyway, all's well that ends well. Thanks for the suggestion, HandySolo, but I won't need it, since the problem is now fixed after all. And thanks to you, BPartch, for the useful but self-evident suggestion. I had always thought that the WordPress files HAD to be in a directory called "wordpress," but apparently not, since now mine are just scattered at the top-level domain. I never knew that was permissible. Otherwise, i would have already tried it!

    Final result: problem solved. Ahhhhhhhhh.

  9. chris586
    Member
    Posted 7 years ago #

    Hello there all,
    the post below, thisis the problem I am having NOW. Seems to have resolved itself for 'dibs' but I am still stuck here.
    Please advise.
    Regards Chris.
    ---------

    "Here's what I'm talking about:

    You know how your own Dashboard is supposed to look? With a certain amount of graphics and layout, etc.? Well, I took a screenshot of how my Dashboard looks, to show you how it is nothing but text. Here's the link to the screenshot:

    http://www.dibsblog.com/screenshot.jpeg

    How can I fix this?

    Posted 9 months ago # "
    ----------------

Topic Closed

This topic has been closed to new replies.

About this Topic