WordPress.org

Ready to get started?Download WordPress

Forums

Trash won't disable and stupid auto-draft (7 posts)

  1. ramicio
    Member
    Posted 1 year ago #

    I can't disable trash. I added "define('EMPTY_TRASH_DAYS', 0);" to the wp-config.php file. None of the trash-related links have changed to "delete permanently." If I trash something, it stays in there for a minute and then disappears. I want the whole trash system disabled, completely. I also have added "define('WP_POST_REVISIONS', false);". I want a clean database with the ID incrementing nicely for one post. I don't want like 10 database entries per post because of revisions, that stupid auto-draft, thing, and trash. Even though it disappears from trash, it bumps up the auto-increment number. What is wrong with this?

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

  3. ramicio
    Member
    Posted 1 year ago #

    That doesn't help me, whatsoever. I don't want any autosave or revision functionality. I want one ID per post. Just making a quick post that just says "test" results in 4 new rows in my database. That's unacceptable.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Now go and read the pages at the links that Krishna posted above.

  5. ramicio
    Member
    Posted 1 year ago #

    Excuse me? It wasn't helpful information. A simple "no, this behavior you describe cannot be attained" would have been helpful. Posting links is not an answer. False and 0 are the same. I've obviously been trying to figure this out and reading a lot. What about the trash BS? Is permanent deletion only available for media?

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    A simple "no, this behavior you describe cannot be attained" would have been helpful.

    And incorrect as even a cursory reading of the first page would have revealed. And, no - 'false' and `0' are not always the same in PHP.

    Is permanent deletion only available for media?

    No - it's also available for Posts * & Pages when you empty (delete) all trash. If this is not appropriate for your needs, try looking for a suitable plugin that allows you to bypass the Trash.

  7. ramicio
    Member
    Posted 1 year ago #

    Well then why isn't it working? If 0 and false were different, it would say so on that page. It doesn't. They're listed under the same function. I've already said what I've added to my config, and nothing changes. This is why this post is in the troubleshooting section. It's not working.

    I have found no such plugin to bypass the trash. If one puts the option at zero, shouldn't WordPress be intuitive enough to say "hey, let's disable the trash system completely and change this 'Trash' link to something like 'Delete permanently'," not just put something into trash and waiting a few seconds for it to delete?

    I want one database entry per post and no trash functionality for posts.

Topic Closed

This topic has been closed to new replies.

About this Topic