WordPress.org

Ready to get started?Download WordPress

Forums

Super Zoom Gallery
[resolved] transparency of zoomed image (6 posts)

  1. Elektra3
    Member
    Posted 1 year ago #

    Sorry to bug you with so many queries, but I have an issue with the transparency of the zoom.

    My zoom part of the gallery floats right to the featured image, so in effect it floats on top of the content area of my page.
    The problem I'm having is now that I can see the text area of my page showing through/on top of my zoomed image!

    Is there a way to change the opacity or transparency, so that the zoomed image is solid and hides whatever is underneath it?

    Thanks in advance!

    http://wordpress.org/extend/plugins/super-zoom-gallery/

  2. Elektra3
    Member
    Posted 1 year ago #

    today I tried it again, and now the superzoom gallery has stopped working altogether when I add text!

    I don't know what else to try....
    how is it possible for text to wrap around image with superzoom gallery??

  3. Elektra3
    Member
    Posted 1 year ago #

    further to my issue:

    because I couldn't get text to wrap around the gallery, I set the szgallery size to 50% (which in effect makes the content that is located to the right of the image show up through the zoomed image (which floats right, on top of the text).

    I think the problem may be that my sz gallery size is too big- my featured image is 360px X 510px, however the actual gallery seems to be 840px X 677px!
    For the life of me I cannot find anywhere to change this!
    Is there a way to change the sz gallery size to that it is confined to 360px by 510px without affecting the way it functions?

  4. Niels
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Elektra,

    No problem, I am glad to help,

    Related to your first post, about the transparancy, the zoomed image is not transparent (except during fade-in and out) but it looks like some other elements are stacked on top of the zoomed image. This is something you might be able to resolve by identifying those elements and changing there CSS by adding a z-index property. This is not the most elegant solution but it might be the only way. The z-index can be used to push the elements down.

    You can also add this line to your theme CSS:
    .szg-zoom-box {
    z-index: 1000 !important;
    }

    Related to your last post about the width of the szg:
    The size of the gallery is now set to 100% of the available width, and the zoombox gets the width of the loaded image.

    You could change the width by using different image sizes (in the media settings of WordPress). Using css is a bit tricky and I don't think you'll get the result you want without changing the javascript as well.

    Hope this helps,

    Niels

  5. Elektra3
    Member
    Posted 1 year ago #

    Wow, adding that line to CSS worked perfectly (and it makes total sense now)! thank you so much, Niels!!! you're awesome! :D

  6. Niels
    Member
    Plugin Author

    Posted 1 year ago #

    Your welcome :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic