WordPress.org

Ready to get started?Download WordPress

Forums

Loco Translate
[resolved] Translation problem (6 posts)

  1. dickmedema
    Member
    Posted 7 months ago #

    Hi Loco,
    I have installed the plugin in my theme and it seems as if the plugin works in the CMS correctly I can edit the. Po working and saving.
    But the translation does not work on the front of the site, translating to en_EN en_US does not get anything translated from the theme.
    The Theme I was using (Red Factory) and Loco plugin also makes tidy .Po to the sentence to be translated and words.
    And CMS translation does not work. Example of Loco plugin itself
    Can you maybe say what I can try to solve this problem
    Regards, Derk

    http://wordpress.org/plugins/loco-translate/

  2. timwhitlock
    Member
    Plugin Author

    Posted 7 months ago #

    WordPress only reads MO files. Is your Loco installation compiling them successfully?

  3. dickmedema
    Member
    Posted 7 months ago #

    Hello Tim,
    Thanks for your quick answer.

    No, it is not generated the .MO, I have a .MO created with Poedit and placed it in the correct folder, and now get the Theme been translated.
    What I do not understand how it works "Configure Loco Translate, Gettext msgfmt" you must enter a path, but I do not understand that, is that a online program/script or is that een program that must installed on the webserver.
    gr,
    Derk

  4. timwhitlock
    Member
    Plugin Author

    Posted 7 months ago #

    msgfmt is a command line program that is part of the Gettext system you install on your server. Loco will try to find it, but if you know the path then enter it. Chances are you don't have it installed.

    If your server is the same machine that you have installed POEdit, then it will have installed msgfmt somewhere, but I can't tell you where.

    The next version of this plugin will have MO compilation built in, but I need to find the time to get round to that. In the mean time you'll have to carry on as you are, using POEdit's bundled version of msgfmt.

  5. dickmedema
    Member
    Posted 7 months ago #

    Hello Tim,

    Thanks for reply, I have learned something again.
    I just checked with two hosting companies where I host sites so they do not support msgfmt.
    I waiting for the next update, I am so happy that Loco Translation makes .PO.
    gr,
    Derk

  6. timwhitlock
    Member
    Plugin Author

    Posted 6 months ago #

    The current development version (1.3.2) now includes a native MO compiler that does not have a Gettext msgfmt dependency.

    http://wordpress.org/plugins/loco-translate/developers/

    The built-in compiler is the default unless you've already set a msgfmt path. Visit the Settings tab to change which compiler is used.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.