WordPress.org

Ready to get started?Download WordPress

Forums

Join My Multisite
[resolved] [closed] translation problem (16 posts)

  1. Boyington
    Member
    Posted 8 months ago #

    Hi,

    thanks for having fixed the wp-signup.php loop problem with your last update.

    Unfortunately, here comes a new one: none of my translations are taken into account with this new version of the plugin :-(

    http://wordpress.org/plugins/join-my-multisite/

  2. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 8 months ago #

    Yes, that was actually noted in the changelog. Sadly you'll have to rebuild them, but the change was to be compatible with upcoming language packs

    See http://ottopress.com/2013/language-packs-101-prepwork/

    http://wordpress.org/plugins/join-my-multisite/changelog/

  3. Boyington
    Member
    Posted 8 months ago #

  4. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 8 months ago #

    I'm not sure. I've honesytly never made a translation file :/

  5. Boyington
    Member
    Posted 8 months ago #

    Did anyone else have the same translation problem ?

  6. Eduardo Larequi
    Member
    Posted 8 months ago #

    I have the same problem, but with spanish translation. I've updated Join My Multisite plugin to version 1.7. Then, I've put join-my-multisite-es_ES.mo and join-my-multisite-es_ES.po files in wp-content/plugins/join-my-multisite/i18n/ folder, but the spanish translation doesn't work.

  7. Boyington
    Member
    Posted 8 months ago #

    I can read on http://ottopress.com/2013/language-packs-101-prepwork/:

    Any calls to load_plugin_textdomain should be in a function attached to the “plugins_loaded” action hook.

    I am not sure you did that in joinmymultisite.php

  8. Eduardo Larequi
    Member
    Posted 8 months ago #

    That hook is not set in the plugin. As far as I know (look at http://codex.wordpress.org/Function_Reference/load_plugin_textdomain ), the load_plugin_textdomain function cant' work with it.

  9. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 8 months ago #

    http://plugins.trac.wordpress.org/browser/join-my-multisite/trunk/joinmymultisite.php#L44

    Yeah, looks like. Okay, lemme kick that.

    If you're willing to try the beta version - http://downloads.wordpress.org/plugin/join-my-multisite.zip - that'd be great. I'm going to spin up a French site as soon as I get to a full computer (and not an iPad).

  10. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 8 months ago #

    Okay, tested, that was it. And now I know where to put the files so they don't get overwritten!

    /wp-content/languages/plugins/join-my-multisite-fr_FR.mo etc.

    I also am suddenly happy I know enough French to get into trouble.

  11. Eduardo Larequi
    Member
    Posted 8 months ago #

    Translations in beta version work fine.

    Thank you, Ipstenu.

  12. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 8 months ago #

    Sweet! Pushed. *fingers crossed I didn't break it again*

  13. bidouilleur
    Member
    Posted 7 months ago #

    Hello Mika, is your plugin translatable already ? Would love to use it on a french MU site but somehow I can get it to translate even with changing the default.mo and .po file
    ??
    thanks

  14. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 7 months ago #

    Yes, it's translatable.

    somehow I can get it to translate even with changing the default.mo

    No idea what that means. Put your translation file in /wp-content/languages/plugins/join-my-multisite-fr_FR.mo and so on. Should work out of the box. It did when I used them from bottapress.

  15. bidouilleur
    Member
    Posted 7 months ago #

    Should have re read my post indeed, not very clear
    Just upgraded WP and your plugin to latest and still it refuses to take in account any translation. Seems it does only read what is hardcoded. All caching disabled server side and browser.

    if I edit settings.php then I see the changes in wordpress. I can set the language files where ever, it just isn't taken in account. In i18n, in /wp-content/languages/plugins/ or the dir just above. The language files are ignored. And my wp is set to fr_FR in config file.

    To say how nasty it is, deleting i18n doesn't affect the plug from working ...
    I can translate all the php files etc but this means next upgrade all will be lost again
    Is there anything I missed ??
    thanks for the help

  16. Ipstenu (Mika Epstein)
    Half-Elf Support Rogue & Mod
    Plugin Author

    Posted 7 months ago #

    I'm really sorry to tell you that I cannot reproduce this problem. However since this topic is resolved, here's what I need you to do.

    1) make a NEW topic for yourself
    2) in that topic, list all the plugins you're using
    3) link to the translation file you're using
    4) tell me where you put it originally that did not work (note where I listed above, which as I've tested does indeed work)

    Since I can't reproduce this, and the original poster in this topic hasn't come back to say it's not working, it's possible to be something on your end.

    (Of note: the only translation related changes recently were fixing the help ones, which were using the wrong call - http://plugins.trac.wordpress.org/changeset?reponame=&new=818609%40join-my-multisite&old=800539%40join-my-multisite )

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic