WordPress.org

Ready to get started?Download WordPress

Forums

Translation problem (5 posts)

  1. luc7v
    Member
    Posted 8 years ago #

    I have an WordPress 1.5 blog, and I translated it in Romanian using ro.mo . Everything is fine.

    Now I started an WordPress 2.01 blog on another site, and I tried to translate it in the same way, but it doesn't work, the blog shows up in English. I checked and re-checked, I don't know what's wrong.

    If you have any suggestion, please help.

  2. moshu
    Member
    Posted 8 years ago #

    Probably the new version (2.0.x) needs a new .mo file - that happens with every upgrade.
    Even if you make it work there would be strings un-translated. And I was wondering shouldn't the mo file be named something like: ro_RO.mo?
    See more details: WordPress_in_Your_Language.
    Also there is a mailing list for the translators
    http://lists.automattic.com/mailman/listinfo/wp-polyglots
    you may want to consider joining it and get more specialized advice.

  3. luc7v
    Member
    Posted 8 years ago #

    I tried another .mo file (for another language), designed for WordPress 2, but still doesn't work. I tried to build ro.mo with my translation, it doesn't work.

    How can I troubleshoot this problem?

  4. frankpereiro
    Member
    Posted 8 years ago #

    I got the the very same problem,

    Did you get to solve it already? I would like to know how to get my blog in my language......I'm tired of writing functions to change months names and things like that when we already have a translation file.

  5. lhk
    Member
    Posted 8 years ago #

    Are you sure you uploaded the .mo file correctly as a binary file?

Topic Closed

This topic has been closed to new replies.

About this Topic