WordPress.org

Ready to get started?Download WordPress

Forums

Multilingual Press
[resolved] Translation deleted, no button to recreate (11 posts)

  1. glen.pike.hf
    Member
    Posted 1 year ago #

    I have a page setup which previously had a linked translation page created for the other language.

    Someone deleted the linked page, but in my editor for the "primary" language page, I select the language to preview and I get a message saying:

    "No post available"

    However, there is no way to "recreate" the translation page for the other language.

    http://wordpress.org/extend/plugins/multilingual-press/

  2. lucaslem
    Member
    Posted 1 year ago #

    Same issue here: translated page got deleted and no way to recreate. Seems like we only get one chance to get it right... there must be something we're missing.

  3. lucaslem
    Member
    Posted 1 year ago #

    Did anyone ever get some feedback to this issue?

  4. toscho
    Member
    Plugin Author

    Posted 1 year ago #

    On the existing page, uncheck This post is translated checkbox, save, and try to create a new related post again.

  5. Milan Dinić
    Member
    Posted 1 year ago #

    This button doesn't exist.

  6. lucaslem
    Member
    Posted 1 year ago #

    As Milan points out, there is no such button.

  7. toscho
    Member
    Plugin Author

    Posted 1 year ago #

    Oh, I see. Sorry, I had the Pro version in my mind. I have added this problem to our list; it is planned for version 1.2. The next version will be a bug fix and stability release, and we don’t want let our users wait.

  8. lucaslem
    Member
    Posted 1 year ago #

    Thanks for the answer and showing good will towards resolving this issue. Sadly, waiting has been a big problem: this issue has been open for 4 months and I have had no choice but to move onto another plugin. Do keep us posted of the next release.

  9. toscho
    Member
    Plugin Author

    Posted 1 year ago #

    A workaround: Go to the table $table_prefix._multilingual_linked (in phpMyAdmin or per console), and delete all rows with the deleted post. Make sure blog_id and element_id match!

    I know, this anything but user-friendly, and the fix wouldn’t be that hard. But it needs goods tests to avoid terrible side-effects, and we don’t have the time for that currently.

  10. anderfelix
    Member
    Posted 11 months ago #

    Hi,

    I have the Pro Version installed, but I have the same issue.
    Is there any way to solve this without aditing the DB?

  11. toscho
    Member
    Plugin Author

    Posted 11 months ago #

    @anderfelix: Currently not, sorry.

    For future questions: you get faster support for the pro version in our support forums, because there are more supporters. I am the only one looking here for open questions, and I don’t have much time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic