WordPress.org

Ready to get started?Download WordPress

Forums

Amazon S3 and Cloudfront
Transfer does not happen (9 posts)

  1. mlautens
    Member
    Posted 1 year ago #

    Hi. I am having a problem with this plug-in. I'm running a single self-hosted WordPress site running version 3.5.1. I used to use the Joe Tan plug in but when I upgraded to 3.5 it stopped working. I was hoping your fork would work for me. But the symptoms are the same. I upload something to the media library, the plugin changes the reference as if it had moved the file to S3, but the file is still on my web server. It's not an S3 credentials thing, because when I click the dropdown it shows me all the buckets, so it IS connecting to my S3 account. It simply does not transfer.

    Any thoughts or suggestions?

    http://wordpress.org/extend/plugins/amazon-s3-and-cloudfront/

  2. jnkfrancis1978mx
    Member
    Posted 1 year ago #

    I'm getting the same problem on one of my hosting accounts, but on another it works just fine, I get the feeling there is something different in the server configuration...

  3. josueochoa
    Member
    Posted 1 year ago #

    Same here, i'm getting the same issue on a multisite installation with 3.5.1

  4. cfkane
    Member
    Posted 1 year ago #

    Having the same issue - files aren't transferring to S3. I'm testing from two sites, both using the same server. Works fine on one, but not the other.

    Downgraded to the older Joetan plugin and problem persists. Leads me to think there's something in the original code base prior to the fork made by Bradt. Disabled all plugins and still can't figure out why it works on one site, but not the other.

  5. Brad Touesnard
    Member
    Plugin Author

    Posted 1 year ago #

    I'm planning to replace the custom S3 library with the standard PHP library provided by Amazon in the next version: https://github.com/bradt/wp-tantan-s3/issues/2.

    There's a good chance this will fix this issue.

  6. mlautens
    Member
    Posted 1 year ago #

    Thanks, Brad. There are enough of us having the problem that we'll be able to give you a quick response on whether that fixes it.

    Now, does anyone have suggestions about a tool that would assist me in sweeping everything that's being presently uploaded to my server into my S3 bucket by changing all the paths for me? (I can move the files easily enough, but adjusting each one of those paths by hand makes me shudder.)

  7. Brad Touesnard
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like the Search & Replace plugin might be an option for you until we build a proper tool to migrate existing media.

  8. mlautens
    Member
    Posted 1 year ago #

    Thanks for the tip! I'll check it out.

  9. Pierre Jodouin
    Member
    Posted 1 year ago #

    Hey Brad,

    Any idea when you'll get around to resolving this issue? I'm not sure if it's the transfer that's not working. The files make it to the S3 bucket but the WP links to the images are broken.

    I'm using 3.5.1.

    Cheers,
    Pierre

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.