WordPress.org

Ready to get started?Download WordPress

Forums

Trailing Slash on main page (5 posts)

  1. tonyleerhone
    Member
    Posted 2 years ago #

    I have a trailing have a trailing slash on my main page. This is not a problem in itself, but when my client tries to paste a link from that page into Facebook, instead of a summary and picture, the Facebook link says "301 Moved Permanently".

    If he pastes the link without the trailing slash, then the link shows properly in Facebook.

    I would like to save him the hassle, and just have the main page be http://www.mydomain.com/blog NOT http://www.mydomain.com/blog/

    I have tried all manner of .htaccess rewrites to no avail.

    How do I remove the trailing slash on the main page?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    What urls are entered in Settings -> General?

  3. tonyleerhone
    Member
    Posted 2 years ago #

    The URLs are http://www.mydomain.com/blog

    No trailing slashes there...or anywhere I can find.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - resetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  5. tonyleerhone
    Member
    Posted 2 years ago #

    Thanks for the great advice, but alas, the problem persists. Strange that it only happens on the blog home page, but not on any post pages, etc...

Topic Closed

This topic has been closed to new replies.

About this Topic