WordPress.org

Ready to get started?Download WordPress

Forums

Trailing slash now required, and buggy admin (7 posts)

  1. Lornholio
    Member
    Posted 1 year ago #

    A bit of a panic this morning! It looks like my WordPress install now requires a trailing slash for a URL to display at all. For Permalinks for my posts this is OK because I can just add a slash to my custom structre, but in many posts and pages I have hard-coded internal URLs without slashes.

    eg.

    http://www.boax.co.uk/mens produces a blank page (not a 404 page)
    http://www.boax.co.uk/mens/ displays fine

    I have changed my .htaccess file now for a quick fix to add a slash so it's kind of fixed things, but the admin system is still problematic. When I hit "Update" or "Publish", my browser's address bar jumps to http://www.boax.co.uk/wp-admin/post.php with a completely blank screen. The post is updated fine, but I need to hit my back button a few times and refresh.

    I'm on an old version of WordPress (3.2.1) so am in the process of backing up everything before attempting an update, but does anyone have any advice?

    Thanks.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try resetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

    And upgrade WordPress asap!

  3. Lornholio
    Member
    Posted 1 year ago #

    I'm pretty sure that the Permalinks aren't the problem. I can make posts work fine just by forcing a trailing slash in my custom Permalink structure.

    The problem is that until yesterday it seemed to not matter if the URL requested ended in a slash or not, eg. http://www.boax.co.uk/mens and http://www.boax.co.uk/mens/ would both display fine. Now if the trailing slash is not included, a blank page appears! I was updating my theme's back-end files all day yesterday (Thematic) but everything worked fine until I checked again this morning, very annoying! With an .htaccess modification I can force the trailing slash to be added, but WordPress's admin is still buggy.

    I'm in the process of a full backup in every way possible (FTP, DB backup plugin and DB via phpMyAdmin) before updating WordPress.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Did you bother trying any of my suggestions?

  5. Lornholio
    Member
    Posted 1 year ago #

    Don't get upset Esmi. As I said, I'm in the process of backing everything up before continuing.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    I can assure you that I am not the slightest bit upset. But I cannot help you to troubleshoot the issue unless you are willing to work with me.

  7. Lornholio
    Member
    Posted 1 year ago #

    OK, allow me to rephrase. "No, not yet but I will."

Topic Closed

This topic has been closed to new replies.

About this Topic