WordPress.org

Ready to get started?Download WordPress

Forums

Trackbacks Not Working (4 posts)

  1. benie09
    Member
    Posted 5 years ago #

    For the past ~two days I've been unable to send or receive trackbacks/pingbacks. I haven't added any plugins or themes that would cause the blockage. My blog is hosted by A Small Orange, the WordPress version is 2.6.5, and the server uses Apache version 1.3.41 (Unix). Does anyone know of any common problems that could cause this? Thanks in advance.

  2. Sarah Anderson
    Member
    Posted 5 years ago #

    Is your xmlrpc.php file accessible? Try going directly to it and see if you get a message about receiving POST info only. If you don't get that then post up anything else you get from that here.

  3. Saurus
    Member
    Posted 5 years ago #

    I get this from a few WP sites in my blogroll (and I theirs) and have given up on trying to figure out why. I have 2 sites who I occasionally comment or trackback to and they NEVER appear on only those two - while they work perfectly on others. That being the case I have to assume it isn't something on my setup, or NONE would work.

  4. Sarah Anderson
    Member
    Posted 5 years ago #

    No it's usually the host blocking access to the xmlrpc.php file as most hosts will treat it as a security issue, however you can get around this using htaccess or renaming your xmlrpc.php file and just updating your header to point to the new file as the pingback file.

    Easiest option is to go to the site's pingback file and see whether you get a 406 error or not (I'm sure other errors can display too, I've only seen a 406 error on this however). If you do then that's the problem, if not then it could be a less obvious issue.

Topic Closed

This topic has been closed to new replies.

About this Topic