WordPress.org

Ready to get started?Download WordPress

Forums

Trackbacks and WordPress 2 (incoming and outgoing) (7 posts)

  1. rawcarrot
    Member
    Posted 8 years ago #

    Hi there,

    I've tried googling and searching everywhere for a solution to my particular problem, but with no luck.

    Basically, having upgraded to WordPress 2 from WP1.5 I now find that my site is unable to send trackbacks to other sites (with the url to trackback to simply sitting in the "to_ping" column in the wp_posts table in my database).

    Furthermore, incoming/inbound trackbacks do not work correctly. The trackback is 'recorded' in as much as the "comment count" in the wp_posts table is added to, but the actual trackback is not recorded in the wp_comments table.

    The result is that some of my posts will say "There have been 4 responses", but because two were trackbacks, only 2 comments actually appear.

    I've tried a number of things (including the 'patch' available here: http://blog.serv.idv.tw/2005/12/29/380/

    I've also gone through some of the code myself but not seen anything obviously wrong.

    If anyone has any ideas on why this might be going wrong and/or what to do to fix it then I'd be most grateful - as it is annoying not being able to trackback to other articles, and doubly-annoying to have to continually check that the "comment count" in the posts table is actually accurate!

    Also, if anyone has the same problem then please post and let me know - so that we might learn whether this is an isolated problem, or, as i suspect, a more widespread problem.

    Best wishes

    Raw Carrot.

  2. rawcarrot
    Member
    Posted 8 years ago #

    Update: Have continued google searching for the answer, but to no avail. Has anyone come across the same problem?

  3. rawcarrot
    Member
    Posted 8 years ago #

    I think I shall move my discussion to this (longer) thread:

    http://wordpress.org/support/topic/54145?replies=164

  4. shiner25
    Member
    Posted 8 years ago #

    Welcome to 2.0 Hell... in my opinion whoever they let loose on create 2.0.. needs to backaway from the computer and never touch a keyboard again..

    Whoever created 1.5 please come back.. :)

  5. rawcarrot
    Member
    Posted 8 years ago #

    Yeah... I've gone through the code line by line and just cannot seem to find the cause of my problem... It's really rather infuriating...

    I get the impression that my problem CANNOT be caused by a major problem... And yet looking at the code nothing seems to be obviously wrong. I've tried disabling plug-ins, enabling different combinations of plug-ins, different themes, hmmm... I would do a fresh install and migrate the database, but I have a horrible feeling I'd just find the same problem and end up having wasted far too much time.

    I should have just stayed with 1.5...

  6. groovenectar
    Member
    Posted 8 years ago #

    Welcome to 2.0 Hell... in my opinion whoever they let loose on create 2.0.. needs to backaway from the computer and never touch a keyboard again..

    Whoever created 1.5 please come back.. :)

    you're getting a FREE, state-of-the-art web application here. stop and think how much it would cost a company to pay a development team to create something like this for the company. the WP team is releasing WP to the world for FREE. it may have its quirks, and we've all got different setups, but there's no denying that it's good, well-written web software.

  7. rawcarrot
    Member
    Posted 8 years ago #

    Sure, it's *very* good for the most part; I'm just disappointed that the upgrade process had informed me of the problem with Trackbacks under PHP as CGI.

Topic Closed

This topic has been closed to new replies.

About this Topic