WordPress.org

Ready to get started?Download WordPress

Forums

Trackbacks ! (16 posts)

  1. e-head
    Member
    Posted 9 years ago #

    I'm guilty of "hacking" (more like screwing up :) my wordpress installation to death.

    Now ... are trackbacks supposed to get spit out during the comments loop in wp-comments ?

    Are there special tags to spit out the trackbacks ?
    I may have just deleted them for all I know, after installing wordpress.

    I tried to do a trackback from my test blog to my "real" blog, but nothing really cool happened, and I was expected bright lights and pretty colors.
    :)

  2. 7milesdown
    Member
    Posted 9 years ago #

    I just recently got my trackbacks going, but Im not sure how to get others trackbacks to appear on my site either...LOL. looks like we are both clueless

  3. e-head
    Member
    Posted 9 years ago #

    Hey, I'm going to track you back with an entry right now ... I think your supposed to see a little diddy (like a comment) on your original entry, pointing back to my entry.

    I'm going to try it with a Doctors Note.

    my blogs here:
    http://dotsandloops.net

    Note : I think you have to allow pingbacks for this to work (see post entry in admin page).

  4. NuclearMoose
    Member
    Posted 9 years ago #

    Assuming you allow *backs, they should appear automagically in your comments section. There were some 1.2 installs that had a trackback bug, but that has been addressed in later builds.

  5. e-head
    Member
    Posted 9 years ago #

    we need a trackback testing place ...
    would somebody be kind enough to trackback one of my posts ? just so I can see if it works ?

  6. e-head
    Member
    Posted 9 years ago #

    O.K. , i managed to successfully ping back another blog ... but it's hard testing the other direction.

    Is "Allow Pings" in the Post entry form where you enable trackbacks ?

  7. NuclearMoose
    Member
    Posted 9 years ago #

    What version of WP are you using, e-head?

  8. e-head
    Member
    Posted 9 years ago #

    I'm using 1.2.1 NM.

    I DO have the "Allow link notifications from other Weblogs" option checked.

    Having said that, I have "hacked" a bit on the wordpress code.

    Should I see a "trackback.php" entry in my apache log ?
    Can you give me something I can search for in the apache log to see what's going on ?

  9. Upgrade to WP v1.2.2, the xmlrpc.php file was updated.
    http://wordpress.org/development/2004/12/one-point-two-two/

  10. 7milesdown
    Member
    Posted 9 years ago #

    thanks. did it work? how do you know? errr.......Im lost.

  11. e-head
    Member
    Posted 9 years ago #

    Thanks macmanx,

    I have been having that login problem too, so I guess I need to upgrade.

    Now I'm gonna have to "diff" all the files to find all the little "hacks" I've introduced ... ohh well.
    :)

    That's why people say to use the myhacks file I guess.

    I just installed all this stuff a couple of weeks ago and I've sort of gone wordpress bonkers ... hopefully I'll get it right this time !

  12. e-head
    Member
    Posted 9 years ago #

    7miles:

    you have to copy the trackback link off my site (here you go):
    http://dotsandloops.net/blog/2005/01/10/trackback-test/trackback/

    Now make an entry on your site, and paste this into the "TrackBack an URI (Separate multiple URIs with spaces.)" field.

    Then a little comment should pop up on my blog.

    btw, I couldnt trackback your post ... so you may need to enable it in your Options -> Discussions section. You need to have "Allow link notifications from other Weblogs (pingbacks and trackbacks.)" checked.

  13. 7milesdown
    Member
    Posted 9 years ago #

    It is checked. Its been checked since I started with WP. Hmmm. very interesting that its not working. I tried to ping back your site and I have the same problem. Nothing is showing up. Grrr.

  14. tomatoma
    Member
    Posted 9 years ago #

    mmm I've just upgraded to 1.2.2, and my trackbacks are working nicely with clean urls, but if use the "pinging list" in "options - writing options", both incomming and outgoing trackbacks stop working ¿Am I doing something wrong?

    thanks

  15. kapeka
    Member
    Posted 9 years ago #

    I observed the same strange behavior like tomatoma. My Trackback didn't work. After deleting the Pingback URLs in the writing Options it works suddenly.

  16. araneo
    Member
    Posted 9 years ago #

    tomatoma and kapeka's trick solved my problem as well.

    This has to be a bug, right? I can't see why it would be deliberate, unless maybe to stop an infinite loop, but there should be better ways to control that.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.