WordPress.org

Ready to get started?Download WordPress

Forums

Trackback & Pingback related tip/help (16 posts)

  1. Iftekhar Ahmed Amit
    Member
    Posted 5 years ago #

    I can't make the Trackback & Pingback work properly on my wordpress blog.
    Trackback & Pingback related tip/help is needed.
    Please reply in details.

  2. Iftekhar Ahmed Amit
    Member
    Posted 5 years ago #

    I'm using WordPress 2.6.5 as self hosted blog.

    My Blog Link: http://amitbd.com/blog

    Everything works properly except Trackback & Pingback.

  3. leisegang
    Member
    Posted 5 years ago #

    i have this problem also

    everything works except pingback and trackback.

    when i disable all plugins it works, but when activating vipers quicktags pingbacks and trackbacks dont work anymore.

  4. Analiese
    Member
    Posted 5 years ago #

    My pingbacks show up in comments in the dashboard but don't show up under blog post even though they're enable both under settings and post. I have a number of plugins related to comments and tweaked the code. I'm a relative newbie so it's disheartening to see no fix in the forum.http://fairfieldgreenfoodguide.com

  5. 11Mystics
    Member
    Posted 5 years ago #

    Leisegang can you list your plug-ins for us? If your pings work AFTER disabling all your plug-ins then that says one of those plug-ins has something to do with this. Many people are having trouble with pings right now. You might have part of the answer if we can identify which plug-in might be messing with this.

  6. when activating vipers quicktags pingbacks and trackbacks dont work anymore

    I don't see how that's possible. My plugin doesn't screw with that kinda stuff.

    Plus it works fine for me on my blogs.

  7. Easyfunk
    Member
    Posted 4 years ago #

    Same here. I wondered why pingbacks and trackbacks won't work. After reading 11Mytics' hint, I disabled vipers video quicktags and pingbacks working properly again.

    I don't know how this plugin is affecting the ping-functoonality, but there must be a relation. Testet on two diffrent blog.

  8. Any errors in your error log or anything? I can't debug this as I am unable to reproduce the issue.

  9. gregma
    Member
    Posted 4 years ago #

    I can confirm that my blog (2.8) won't sent pingbacks, if the Plugin "Video Quicktags" is active...

  10. 150kgleichter
    Member
    Posted 4 years ago #

    I can confirm that my blog (2.8) won't sent pingbacks, if the Plugin "Video Quicktags" is active, too

    I have test it several times

  11. blogtemporar
    Member
    Posted 4 years ago #

    I found the problem to be a missing code line (2.8.3).

    Apparently, in comments.php (Dashboard -> Appearance -> Editor -> comments.php) there is the following check line:

    <?php if ( !empty($comments_by_type['pings']) ) : ?>

    Testing it, I found that the $comments_by_type variable is NOT SET, hence the IF check will fail and trackbacks and pingbacks won't show.

    To fix this, just add the following line BEFORE the line above:

    <?php $comments_by_type = &separate_comments($comments); ?>

    This simply sets the $comments_by_type variable with the necessary info for the loop to take on pings and trackbacks.

    ----------------------------------------------------------
    Basically it should look like this:

    <?php $comments_by_type = &separate_comments($comments); ?>
    <?php if ( !empty($comments_by_type['pings']) ) :  ?>

    instead of

    <?php if ( !empty($comments_by_type['pings']) ) : ?>
    ----------------------------------------------------------

    Let me know if this has helped you guys out with your versions.

    Cheers,
    Mike

  12. tatoeba
    Member
    Posted 4 years ago #

    Thanks Mike but I don't have that line in my comments.php code (I use 2.7)

  13. lawNew
    Member
    Posted 4 years ago #

    @blogtemporar,

    I have 2.8.4(2.8.3 security problems), and in comments.php i can't find such line.
    Also have Atahualpa theme 3.4.1.

    seems that many people have this problem with trackback and pingback.
    Where is a moderator, when we need one!

  14. This issue was fixed a few months back in my plugin. You shouldn't need to make any file modifications.

  15. stobbsc
    Member
    Posted 4 years ago #

    Ok I don't have those lines in my comments.php

    I still want to beable to test my pingback and tracebacks.

    Does anyone know a site that I can test this on.

    also I don't get the trackback URL thingy at the bottom of my posts :-(

    Please could someone help me

  16. ravelrumba
    Member
    Posted 4 years ago #

    @Mike,
    Your solution worked perfectly. Thanks!

    Rob

Topic Closed

This topic has been closed to new replies.

About this Topic