WordPress.org

Ready to get started?Download WordPress

Forums

SE HTML5 Album Audio Player
[resolved] Track numbers are all zero (12 posts)

  1. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 1 year ago #

    When expanding the list of songs, all of the songs are in the correct order, however they are not numbered - all of them are shown as numbered zero. The MP3s have the track number in the ID3 as well as the beginning of the filename, is there somewhere else the track numbers should be set in the MP3?

    http://wordpress.org/extend/plugins/se-html5-album-audio-player/

  2. sedevelops
    Member
    Plugin Author

    Posted 12 months ago #

    From within the Media Upload dialog for the album post in question, you must drag the tracks into order. It seems unnecessary, I know, if all the tracks are already seemingly in order, but WordPress will not assign the 'menu_order' to to attachments until you drag at least one of them into order.

  3. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 12 months ago #

    That was it! The method you described has worked for me & the audio tracks are now numbered. Thanks for your help.

    I have one further question; is there a way for the player to display with the track list expanded by default without than having to press the button first?

  4. sedevelops
    Member
    Plugin Author

    Posted 12 months ago #

    Glad its all set.

    As for playlist expansio : Not yet. Ill put this into the next update. :)

  5. cubecolour
    ɹoʇɐɹǝpoɯ
    Posted 12 months ago #

    Thanks again, that sounds great. I look forward to playing with your next version

  6. nutman
    Member
    Posted 11 months ago #

    I have this same problem. I have re-ordered them about a million times now and doesn't make one bit of difference. What am I doing wrong?!

  7. sedevelops
    Member
    Plugin Author

    Posted 11 months ago #

    nutman, are you saving the changes within you media uploader dialog after reordering?

    Also:
    what browser, browser version, and OS are you using?

    last, can you post your process of creating an album, step by step?

    Thanks!

  8. nutman
    Member
    Posted 11 months ago #

    I am saving the changes.

    Tried in Chome & Firefox, both latest versions - same result

    Win 7 64bit.

    Create album -> give it a title -> add media -> upload files and then drag into order along the bottom of the media box -> close media box (not inserting into post) -> publish.

    Edit page im adding it to -> Use the SE Albums menu item to select my album and insert the shortcode into the page -> Update page.

    I created another album to see if that would fix it, and rather than upload new files I just selected the existing files within the media upload box. After adding the new album to a page, there were no files in the album. I've also tried changing the attachment display settings from 'embed media player' to 'link to media file' which made no difference.

  9. wp_user_8936819
    Member
    Posted 11 months ago #

    Very nice plugin.

    However, I'm having a similar problem to others. It's probably a simple step we're missing. Cannot get track numbers to become anything but zero. I've re-ordered files in Media Upload dialogue using Edit mode at bottom of page, but I don't think the re-order is being saved.

    If you'd like to look at it via remote access (TeamViewer, LogMeIn, VNC, etc.) I'll can arrange.

    If you make a YouTube video showing the actual, complete process, I'm sure that would be helpful, too.

    Thanks for your help,

    Jim

  10. sedevelops
    Member
    Plugin Author

    Posted 11 months ago #

    Here's a youtube demo video: http://youtu.be/vZAfrzXfD00

  11. wp_user_8936819
    Member
    Posted 11 months ago #

    For the problem of track numbers showing as zeros, your video did the trick! http://youtu.be/vZAfrzXfD00

    In particular, it demonstrated that Uploaded to this post must be selected in the dropdown menu of the Insert Media page.

    Because I'm a novice at this, that wasn't obvious to me, and I suspect that'll be the case with others.

    Is there a place we can make donations for your efforts?

    Looking forward to the update that allows the album to render with all tracks shown as an option. Cool and useful plugin.

    Thanks again.

    - Jim

  12. sedevelops
    Member
    Plugin Author

    Posted 11 months ago #

    Thanks Jim. Glad the video helped.

    I forget sometimes that we've all got different levels of experience with WordPress and that some things are more/less obvious depending.

    No donations necessary. I could pretty easily add a new shortcode parameter, maybe something like:

    [SE_album_player album_id=autoplayer dl=true <strong>tracks_open=true</strong> cover=http://www.metalsucks.net/wp-content/uploads/2013/03/Monkey-Mia-MJK-Australia.jpg]

    ...to let the album display with tracks open by default.

    I'm waiting to hear on a few other support threads to see if I can't also roll out some other fixes at the same time.

    However, if you wanted a quick solution to this problem, just add this line of javascript to your theme:

    jQuery(document).ready(function($){
         $('.se_albumplayer').find('.playlistBtn.icon-list').click();
    });

    It should open all playlists on a page after loading.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.