WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Top-level navigation item should not link to page (8 posts)

  1. mechanical_parag
    Member
    Posted 11 months ago #

    Hi!
    in the menu bar i have parent menu items which are not supposed to link to any page but user should be able to click and link on the child menu.

    Now I have installed a plugin which is page list but I dont know what is shortcode, can somebody help me to solve the problem.
    Thanks
    Parag

  2. WPyogi
    Volunteer Moderator
    Posted 11 months ago #

    Create a custom menu - then use the "Links" (from box on left side of menu screen) to add the top level nav items - once it's in the menu, you can remove the URL (click on the flippy triangle on the menu item to modify that item.

    See: http://codex.wordpress.org/WordPress_Menu_User_Guide

  3. lettergrade
    Member
    Posted 11 months ago #

    I don't think you need a plugin. WordPress isn't really set up to create non-linked parent menu items but here is the trick I use when I need to.

    If you haven't already, maybe review this first: Appearance Menus.

    –While editing your menu, go to the Links box on the left sidebar. Type in a fake link address for 'URL' and the title of your dropdown menu item where it says 'Link text.'

    –Drag your new link over to your menu and place it where you want it.

    –Click the top right arrow on that menu item to open up its options.

    –Delete the fake link address from the 'URL' field. (this stops it from being a clickable link, and means it's only a dropdown menu parent)

    –Move your child menu items underneath the menu item you just created so that they become a dropdown menu.

    –Save your menu, make sure it's assigned where you want, and check your site.

    Aside: Here is some information on shortcodes, though it may be more than you need.

  4. esmi
    Forum Moderator
    Posted 11 months ago #

    Uh? See WPyogi's response above.

  5. lettergrade
    Member
    Posted 11 months ago #

    Simulpost, @esmi.

  6. mechanical_parag
    Member
    Posted 11 months ago #

    thanks Mr Lettergrade, many thanks to you it solved my problem so easily that i could not believe. many thanks to you Lettergrade once again.

  7. lettergrade
    Member
    Posted 11 months ago #

    Awesome, very glad it's all sorted out.

  8. Di Rogers
    Member
    Posted 3 months ago #

    Thank you from me as well lettergrade. What a simple solution! Worked perfectly.

Reply

You must log in to post.

About this Topic