WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
Top level content is not appearing (9 posts)

  1. natehawkes
    Member
    Posted 1 year ago #

    I have recently deactivated Polylang, as it has been causing some confusion with content on my WordPress site. My top level pages have all "disappeared" from view (They are replaced with the home page, regardless of what page I view). Any second level content will appear normally, but only my top level content will not display. Regardless of the settings I have used in Polylang, this has been my issue. Now that I have deactivated the plugin, the issue remains. Can anyone offer a solution?

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    A deactivated plugin (Polylang or any other) does nothing. If your problem persists with Poylang deactivated, it most probably means that your problem is comeing from elsewhere.

  3. Tierra Quebrada
    Member
    Posted 1 year ago #

    I'm having the same problem.

    After intallation of Polylang all seems to work fine except for top level pages.
    All content of top level pages is ok and in database but when trying to acces it redirects to default posts-page.

    Before installation all pages work fine without any problem.

    Trying different combinations of polylang parameters seems not to work for now.

    Thecnical details:

    Settigns for Permalinks:

    http://www.tierraquebrada.com/%year%/%postname%/
    Static inital page instead of posts page

    Settigns for Polylang
    Actually only 2 languages
    Detect browser language: on
    Use language code as suggested with wordpress seo
    remove language in permalinks
    Hide url for default language
    media translation: on
    Sync: all on

    Description:
    it's a working site adn just now added polylang

    Problem:
    In some top level pages links doesn't work as expected and always redirect to posts pagenor the correct static page.

    You can see in all top level pages redirected to same posts page
    http://www.tierraquebrada.com/vive-tu-propia-aventura/
    http://www.tierraquebrada.com/el-mundo-de-tierra-quebrada/
    http://www.tierraquebrada.com/quienes-somos/

    These 3 pages should show diferent information but all of them redirects to
    http://www.tierraquebrada.com/la-vieja-puerta-de-roble/
    (url to publish posts)

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @Tierra Quebrada: It seems that Polylang is not active on your website

  5. zearth
    Member
    Posted 1 year ago #

    I got this problem also on my local/test server, all top level pages are 404, I tried to disabled all plugins and polylang is the only plugin activated.

    when I disabled polylang it works fine.

  6. zearth
    Member
    Posted 1 year ago #

    I found the issue on polylang.php

    // optionaly removes 'language' in permalinks so that we get http://www.myblog/en/ instead of http://www.myblog/language/en/
    		// language information always in front of the uri ('with_front' => false)
    		// the 3rd parameter structure has been modified in WP 3.4
    		add_permastruct('language', $this->options['rewrite'] ? '%language%' : 'language/%language%',
    			version_compare($GLOBALS['wp_version'], '3.4' , '<') ? false : array('with_front' => false));

    I remove this code temporarily, it seems the code is forcing to add "language" on permalinks which causing the root/parent pages to go 404 error.

    but the issue now if I remove this, it add "language" on the root/home page.

    Can you try check the correct solution on this error, I've tried this using old and new setup wordpress and it showing this error.

  7. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @zearth: if you remove this line, you are likely to break all the links in which the language code is needed.

    The presence of /language/ in the permalink is controlled by an option in polylang settings. I don't know why but on some installations, it is needed to make permalinks work correctly. That's the reason of the option.

    Until now I did not reproduce any issue with top level pages.

  8. zearth
    Member
    Posted 1 year ago #

    ok but I'm not sure why the top level and parent page directing to 404, even I used only this plugin in a new installation.

    can I know the functions that handle the page URL so I can check why it goes 404 on the parent/top pages?

    thanks

  9. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Did you use a default theme (twenty twelve) for your test?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.