WordPress.org

Ready to get started?Download WordPress

Forums

Top 10 - Popular posts plugin for WordPress
Top 10 & W3 cache (Display number of views on posts) (17 posts)

  1. Carlos Revilla
    Member
    Posted 2 years ago #

    So, I switched my cache to W3 from Quick Cache (much better by the way). I´m having this issue: I checked "Display number of views on posts" and then sometimes (with some posts, lets say randomly) it shows the post for a few seconds and then automatically jumps (loads) to a white screen with just the Top 10 numbers for that post.

    Unchecking "Display number of views on posts" or disabling W3 and keeping option checked, everything is just fine.

    I´m using other plugins that place info at bottom of post. You can take a look at http://cambiopolitico.com

    At this moment number display on posts is unchecked.

    Carlos

    http://wordpress.org/extend/plugins/top-10/

  2. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Carlos,

    It seems to be a clash between Quick Cache and the way it processes the JS code.

    Am not familiar with Quick Cache. I'll have to check what settings it has to offer and if one of those particular ones is causing an issue.

    Can you confirm, but there shouldn't be an issue with W3?

  3. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    You can try one option:

    Under "Don't Cache These Special URI Patterns?" options in Quick Cache, you can add a new line for top-10

    The current default list is:

    wp-app
    wp-signup
    wp-register
    wp-activate
    wp-login
    wp-admin
    xmlrpc

    Let me know if this works?

  4. Carlos Revilla
    Member
    Posted 2 years ago #

    I´m sorry, I was missunderstood. The problem I'm having is with W3 cache. So, I'm confirming there is an issue with W3 (at least for me).

    Thanks for your help.

    Carlos

  5. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Apologies... I miss read. I've not faced a problem in all my testing.

    Do you have the JS optimising settings on in W3 Total... i.e. JS minify?

  6. Carlos Revilla
    Member
    Posted 2 years ago #

    Ok, JS minify is enable, all other settings in JS are unchecked

    Carlos

  7. Carlos Revilla
    Member
    Posted 2 years ago #

    I just checked W3 settings again, as I said JS minify is enable, and all other settings in JS are unchecked, but in general settings minify is not enable. Could this affect? Maybe now that i´m using w3 you could give me the best setting to use with Top 10?

    Displaying the post nunbers is a nice option that I would like to keep. Again, thankyou for your help.

    Carlos

  8. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Could you try disabling the JS minify option?

    Alternatively, is there an option to set top-10 as an exclusion?

  9. Carlos Revilla
    Member
    Posted 2 years ago #

    I tried w/o minify Bit still no luck, the issue keep showing ramdomly.

    Carlos

  10. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Carlos, I've posted in the W3 Total Cache folder to see if there is a solution.

    Am also going to create a workaround in Top 10, however, this might not be ideal since the counts might be old

  11. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Not sure if you tried but can you add top-10 in the "Never cache" related box on the Page Cache Settings tab. apologies I don't know the exact setting name, since I don't have this configured anywhere.

  12. Carlos Revilla
    Member
    Posted 2 years ago #

    I have two options in w3

    1. Never cache the following pages
    2. Cache exception list

    Wich one should use, and wich .php file should use too.

    Carlos

  13. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    You can try top-10-counter.js.php

  14. Carlos Revilla
    Member
    Posted 2 years ago #

    Ok, placing top-10-counter.js.php in W3 Cache exception list seems to work. Since last saturday (after applying the fix) I didn't have any issue displaying number of views on posts. I wi8ll keep checking, but for now seems to be resolved.

    Thanjs for all your help and for a great plugin.

    Carlos

  15. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you for checking. Please let me know if an issue crops up.

    What is the exact field you entered this in?

  16. Carlos Revilla
    Member
    Posted 2 years ago #

    Ajay, i´m sorry to tell you that the issue appeared again in a random fashion. So i disable "Display number of views on posts" again.

    Carlos

  17. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for letting me know. It is indeed quite weird!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags