WordPress.org

Ready to get started?Download WordPress

Forums

Crayon Syntax Highlighter
Toolbar not working and no horizontal and vertical scrolling! (9 posts)

  1. ridgey28
    Member
    Posted 1 year ago #

    Hi
    When I click on any of the toolbar buttons it doesn't do anything and horizontal and vertical scrolling does not work also.

    I have narrowed it down to problem with Total Cache. What are the recommended settings for Crayon to be compatible with Total Cache or is it just a case of trial and error?

    http://wordpress.org/extend/plugins/crayon-syntax-highlighter/

  2. Dragon Flyers
    Member
    Posted 1 year ago #

    Hi, ridgey.
    Same problem as me, this not work if mix with W3TC (WordPress Total Cache). All toolbar didn't work.
    Maybe the author could help our problem :)

  3. akarmenia
    Member
    Plugin Author

    Posted 1 year ago #

    Hi guys, can you provide URLs so I can debug the issue?

  4. akarmenia
    Member
    Plugin Author

    Posted 1 year ago #

  5. ridgey28
    Member
    Posted 1 year ago #

    Hi

    I have narrowed it down to the JS minify settings in Total Cache. When it is enabled the toolbar doesn't work correctly. What are the recommended settings to minify JS and make it compatible with total cache?

    Cheers

    Tracy

  6. ridgey28
    Member
    Posted 1 year ago #

    I have managed to get around the total cache problem by installing MinQueue. There is a little helper for signed in users that displays all the scripts and styles then you can manually choose which Javascripts and CSS to compress.

  7. akarmenia
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks, all I did was to enable minify in the settings of W3TC and I didn't take any additional steps. Can you provide a URL so I can take a look at what JS errors are being returned in the error console?

  8. ridgey28
    Member
    Posted 1 year ago #

    I went back to the total cache plugin after the recent update to see if I could rectify the problem. I have tried various settings including just minifying the crayon files but to no avail I cannot figure it out. Try looking at the following URL

    Do you minify your files before the head, before the opening body tag or before the closing body tag?

  9. akarmenia
    Member
    Plugin Author

    Posted 1 year ago #

    It seems yours occurs in the footer before the < /body> so that might be why - can you get it working with the default wordpress theme? If so, then the issue is likely your plugins. If not, then it's likely the plugins. That'd be my first approach to debugging the issue since it'll split the problem in half.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic