WordPress.org

Ready to get started?Download WordPress

Forums

'Too many redirects' error and Permalinks (25 posts)

  1. TransientMusic
    Member
    Posted 2 years ago #

    Hi all, I've been looking all over the forums, conducting google searches etc but I still cant get this problem resolved.... although I think I know where the problem is now, but it doesn't work as I would like!

    Anyway, the initial problem: All of a sudden it was impossible to access my site from the front page, although typing in a page address would work. The error I (and others) got was the 'too many redirects' one when trying to open the page. It did this for any page being assigned as my front page, except for when the blog was at the front.

    So, I saw some advice on custom permalinks and set my link structure back to default. It now works! But I still get the problem even if I choose a permalink option other than 'custom', it only works on default. Any ideas how I may get these 'pretty' links to work again..? I did see mention of the host server not having the right software, but I'm with Network Solutions so I'm thinking this is unlikely....??

    Any help would be much appreciated!

    Here is my site if you need it: http://www.Jay-Harris.co.uk

    thanks,

    Jay

  2. TransientMusic
    Member
    Posted 2 years ago #

    I should also mention that I tried disabling all pluggins, and that had no effect.

    cheers,

    Jay

  3. jamesostrand
    Member
    Posted 2 years ago #

    I'm having the same trouble. Did you get this resolved?

  4. kilakiwi
    Member
    Posted 2 years ago #

    Are you using Yoast's SEO plugin, by any chance? I kept having this problem until I unchecked the options on the Yoast SEO plugin dashboard to set category permalinks. It was conflicting with my security plugin and my category re-direct plugin and causing too many re-directs.

  5. Tullah
    Member
    Posted 2 years ago #

    Same problem here. I want 'pretty permalinks' too, but keep getting some pages that say 'too many redirects'. So end up going back to the default URL's

  6. jamesostrand
    Member
    Posted 2 years ago #

    No Yoast.

    What's strange is that I don't get the re-direct error ALL of the time. I installed the Permalink Fix & Disable Canonical Redirects Pack plugin, but I'm not seeing much improvement in the reliability of my URL.

    Is this a WordPress problem or is something going on with my hosting company and/or domain registrar?

  7. kilakiwi
    Member
    Posted 2 years ago #

    Do you have Bulletproof security and/or a plugin to hide /category/ on your URLs?

    I only started seeing the problem after the last WordPress update, which coincidentally, added an automatic /%postname%/ permalink option.

  8. TransientMusic
    Member
    Posted 2 years ago #

    Hi all,

    yeah still having the same problem:

    Pluggins don't seem to change it whatsoever but these are the plugging I have:

    Audio player
    Disable Parent Menu Link
    Google Analytics for WordPress
    Jetpack by WordPress.com
    TinyMCE Advanced

    Theme I'm using:

    Twenty Eleven and as this was made by WordPress I can't see this being the problem...?

    Anyone notice any similarities to my set-up..?

  9. TransientMusic
    Member
    Posted 2 years ago #

    ps @jamesostrand

    'Permalink Fix & Disable Canonical Redirects Pack' didn't work for me either.

    There must be some similarity between our cases..??

  10. kilakiwi
    Member
    Posted 2 years ago #

    I should have mentioned that I had to go back to the Settings >> Permalinks page on my dashboard and re-save my options after I found the problem. It didn't work until after I did this.

    I think there's something wonky with the new automatic 'Post name' option.

    If you've turned plugins off, and especially if you are using the 'Post name' setting under permalinks, try that. Caveat: If the issue seems to be fixed, go back and click on your posts from your main page a few minutes later to make sure it doesn't revert, because mine did until I got the right fix.

  11. TransientMusic
    Member
    Posted 2 years ago #

    I'm afraid that hasn't worked for me... Did anybody get this resolved...?

  12. Point Clear Media
    Member
    Posted 2 years ago #

    I'm having the same problem. I keep getting the Too Many Redirects Problem.

    I cannot use the 301 redirects on Yoast's SEO plugin, nor can I use the Force SSL on WordPress Https plugin.

    Same problem with all plugins deactivated.

    The site is on Network Solutions VPS hosting, and they have been pretty awful about providing me any information with this product.

    I am not having this problem with the same exact setup on Hostgator.

    Could it be a folder ownership issue? Maybe even at a higher level than the root folder?

  13. kilakiwi
    Member
    Posted 2 years ago #

    After you make sure that your WordPress, theme, and plugin installations are all updated, deactivate all of your plugins, go back to Settings>>Permalinks in your dashboard and re-save your permalink settings. Then click several posts to make sure it's working. Just to be safe, log out, use a different browser, and check again.

    Also, make sure that you are not using two methods of stripping the /category/ from your category page URLs, such as "WP-No-Category-Base" and Yoast's WordPress SEO plugin with category stripping enabled under the Permalink section, because that will definitely cause this problem.

  14. Point Clear Media
    Member
    Posted 2 years ago #

    Kilakiwi

    Thank you for your help, although this did not work.

    I tried disabling Yoast completely and have no other category stripping plugins in there. Still no luck.

  15. Point Clear Media
    Member
    Posted 2 years ago #

    One other thing, I still get the too many redirects even if the default permalinks is set with the ? page id URL.

    The whole site works fine except when I try 301s or forced https.

  16. kilakiwi
    Member
    Posted 2 years ago #

    Mobile251, Have you tried rebuilding your .htaccess file?

  17. Point Clear Media
    Member
    Posted 2 years ago #

    I have done this nd re-uploaded it. Do you think it might be that I have a cname and an A record for the domain? I have to check with the mx manager before I remove the cname to test.

  18. kilakiwi
    Member
    Posted 2 years ago #

    mobile251, I have no idea about that, but your host tech support might be able to tell you. If you can't get this resolved, you can email me at kwhite(at)crunchydata.com and I'll try to help you.

  19. TransientMusic
    Member
    Posted 2 years ago #

    kilakiwi, I tried your methodology once more and it worked this time! I have no idea what I did differently but all seems to be working as it should be now... Many thanks!

    Jay

  20. kilakiwi
    Member
    Posted 2 years ago #

    Jay, I'm happy to hear that it's working for you now!! You should still click on a few posts in the next day or two to confirm that the fix us "holding." Mine would work for awhile, then revert until I figured out that my SEO plugin was causing the problem, and after fixing that, I still had to re-save my Settings >> Permalinks again to fix it permanently. Best wishes!
    Kim

  21. TransientMusic
    Member
    Posted 2 years ago #

    Great, thanks for the tip Kim. I'll do a double check tomorrow!

  22. Point Clear Media
    Member
    Posted 1 year ago #

    OK, I finally got this fixed. It turns out that my SSL was installed incorrectly. I determined this when I realized that my 301's were working to http pages but not https pages.

    After many painful phone calls with Network S.O.L.-utions I got this resolved. Now it's working.

    Although, concurrently I upgraded the WordPress Https plugin and it now doesn't put a forward slash before child pages in the URL. Since it is a brand new site I was able to just make all secure pages 1st level pages with no harm done.

  23. jurajpuchky
    Member
    Posted 1 year ago #

    I had same problem fixed with my plugin

    http://wordpress.org/extend/plugins/fix-multiple-redirects/

  24. erubinp
    Member
    Posted 1 year ago #

    I had the same problem...I had to go to permalink and disable category

  25. nasca
    Member
    Posted 1 year ago #

    Go to php my admin (database). Click on the options table. It might be wp_options or whatever table prefix you use. Click on the SQL tab at the top of the page.

    Run this query:
    SELECT * FROM wp_options WHERE option_name = 'active_plugins';

    Delete contents form the row returned by the query(all your doing is deactivating all your plugins).

    Click GO.

    Refresh your site. Log in. Enable the plugins one by one to see which one was causing the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic