WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Too many redirects and dashboard not working (5 posts)

  1. wowzimmer
    Member
    Posted 1 year ago #

    I have come seriously unstuck on attempting to set up the multisite feature with a new domain that is not a sub-domain or sub-folder.

    I have been following the instructions in a 'For Dummies' book and consulting the internet where necessary. Multisite installed without a hitch from my single WP install, version 3.5.1. I installed it in the document root and the intention was to add a separate domain using the MU Domain Mapping plugin.

    However, having updated my .htaccess file, changed over the DNS and added the new domain I have encountered two main problems:

    1. Firstly, when I navigate to my original website the following message is returned:
    "Too many redirects occured trying to open ....".
    2. Secondly, the new website is loading with the standard WP homepage. However, I can't access the dashboard. If I attempt to navigate to /wp-login I get a 404 error and a redirection to my web host.

    I've spent a fair amount of time on Google trying to remedy this problem myself but to no avail. Any ideas would be greatly appreciated. I get the impression that I either have an error on the .htaccess file or even the database from what I have seen on Google but Idon't know how best to proceed!!!

  2. What's in the .htaccess? :)

  3. wowzimmer
    Member
    Posted 1 year ago #

    This is what was copied onto the .htaccess file when I set up the multisite:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    # END WordPress

    If I believe was correct as I was setting up multisite from V.3.5?
    I haven't made any other additions or changes to the .htaccess file

  4. Well it's missing an end to the if module, but that's not going to give you a redirect loop.

    You have to do things in order.

    1) Install WP, make sure it works.
    2) Turn on Multisite, make sure it still works.
    3) Make a sub-site, make sure it all still works.
    4) Domain mapping, make sure it all still works.
    5) Beer.

    Yes, you should be stopping between each step to make sure everything still works :)

    When did the redirect loop start? Right after you turned on Multisite or right after you turned on domain mappin?

  5. wowzimmer
    Member
    Posted 1 year ago #

    Aha! I've learnt an important lesson with this one... Always back up your blog!

    Delving into my WP files I made changes that I quite frankly couldn't trace or put right. As the install was nearly new anyway the simplest solution was just to uninstall all the files and databases from my web host and start over.

    At least Multi-user is now working and I have successfully set up a new domain (separate from the original):

    • This time I used Fantastico and checked the 'multi-user' option
    • I made back-ups of the databases along with the following files : wp-content file, wp-config file, .htaccess file at key points
    • As Ipstenu rather wisely suggested I checked that the site and dashboard were working as I went through the process

    All is now good!

Topic Closed

This topic has been closed to new replies.

About this Topic