WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Too many posts showing.... (8 posts)

  1. ddamron44
    Member
    Posted 3 years ago #

    Currently, about 20 posts are showing on my site. I only want the latest post to show in its entirety on the front page. I have asked this question before and everyone tells me to go to settings>reading. I have and I have it set at 1 (see image linked here: http://lifeexcursion.com/wp-content/uploads/2010/10/toomanyposts.jpg ).

    How do I get my site to only show one post?

    Lifeexcursion.com

    Appreciate your help...

    David

  2. obscure
    Member
    Posted 3 years ago #

    If the dashboard setting is being overruled it is most likely a theme specific setting or else a plugin. What theme are you using and what plugins do you have installed.

  3. FantasyPC
    Member
    Posted 3 years ago #

    Try add this to your index.php page to the following

    <?php query_posts('showposts=5'); ?>

    I got this from here. http://www.webdesignerwall.com/tutorials/wordpress-theme-hacks/

    also try reading
    http://codex.wordpress.org/Function_Reference/query_posts

  4. ddamron44
    Member
    Posted 3 years ago #

    FantasyPC---

    Thanks but I tried adding ...
    <?php query_posts('showposts=2'); ?>
    ....to the index.php file and it didnt work.

    Is there somewhere specific I should place it within index.php.

    By the way, I am using Karappo theme

    Thanks...

    David

  5. MichaelH
    Member
    Posted 3 years ago #

  6. ddamron44
    Member
    Posted 3 years ago #

    Hey MichaelH---

    Tried that plugin with no success.

    Thanks for trying though. It must be something in the theme but I cant seem to find it.

    David
    LifeExcursion

  7. MichaelH
    Member
    Posted 3 years ago #

    Just downloaded and installed http://wordpress.org/extend/themes/karappo-style and in Settings->Reading set Blog pages show at most to 1 and it worked just fine.

    Maybe a plugin causing the problem or that theme has been customized.

  8. ddamron44
    Member
    Posted 3 years ago #

    I deactivated all plugins = Fail...

    I have checked the single.php file, index.php file, and functions.php and can't find any coding error.

    Any idea as to which .php file it may be in?

    Thanks...
    David

Topic Closed

This topic has been closed to new replies.

About this Topic