WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] too many pages? pages seem to timeout. (11 posts)

  1. jcow
    Member
    Posted 7 years ago #

    I have a site that worked perfect on my dreamhost server. I moved it to a client's server and now it appears that if I have over a certain amount of pages (60ish), things go haywire.

    After a certain amount of pages are added, here are the symptoms:

    under Options >> Reading, it quits part way down the page. (screencap: http://starkmanclients.com/options-reading.gif)

    When I publish a page, it goes to blank. nothing, just white. no errors at any point. But it does save the page, if I go to the page list using back or manually typing in url again.

    When I view a page on the actual site, it seems to quit rendering at a certain point on each page. I have a limited sitemap and menu at the bottom each page, and most pages quit somewhere within that. it is different for each page. Some pages don't make it thru the menu, some get the menu, but don't finish the sitemap. a couple actually get through most of it.

    Could this be a server timeout issue? or possibly a php memory size limit?

    Everything is exactly the same as the past server. I have moved sites before, but never with so much trouble. i even went back in and started to add pages manually thinking the database might be messed up, but eventually it did the same thing when i hit too many pages...

    I am at a loss. I have done a lot of reading on the support forums here, but haven't found anything quite like this and no real clues...

    any help or point in the right direction would be great.

    thanks.

  2. Andrew Ozz
    WordPress Dev
    Posted 7 years ago #

    Perhaps the host is limiting the memory usage/cpu usage/number of queries/connections to the db/etc. Most cheap hosting plans have these limitations.

  3. Bodhipaksa
    Member
    Posted 7 years ago #

    I have about 10 times as many pages as you, and the only problem I have is that the dashboard loads the list of pages very slowly. I don't think you're experiencing a WordPress limitation.

  4. jcow
    Member
    Posted 7 years ago #

    I really don't think it is a wordpress issue as well. I have no idea what it is, but I have used many installations of wordpress and I have moved almost all of them from one local server to a live server or from a live to another live. No issues that couldn't be easily troubleshooted. this one is baffling. And there aren't that many pages...

    This isn't a simple cheap host, but it certainly isn't fancy. I believe it is dedicated. We have an IP address only for the client's own sites...

    I may just have to give up until the client's admin guy comes around and either fixes it, or we move it to another server.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    I'd view the source of the resulting HTML output and see where, exactly, it stops processing. You may just have some strange page name or something that messes up the display.

  6. jcow
    Member
    Posted 7 years ago #

    It isn't in the same place everytime, but I will take a look at the page names, maybe there is something off...

  7. jcow
    Member
    Posted 7 years ago #

    For the record. This was the nefarious Apache 8mb setting. We bumped it up to 32mb and smooth sailing. What a pain in the ass.

    Basically anytime a page had to access the complete list of pages in the database too many times(even if it was to pull out a few child pages), it would push the rendering past that 8mb mark. So some pages were fine that didn't have as much going on and the ones that accessed multiple times were the worst.

    This, of course, screwed up the back-end as well and also affected certain plugins. When I installed the site on dreamhost's basic shared account and mediatemple's grid server, I had no problems what-so-ever and installed the complete site working in a half-hour. So I don't know what their default settings are, but they appear to be over 8mb.

    I don't understand this issue completely, but maybe this will give somebody else some direction in the future. Probably more likely to happen with a smaller host who sets up their own servers with default settings.

    Anyhow. the server is smoking fast and working now.

  8. Bodhipaksa
    Member
    Posted 7 years ago #

    That's interesting. Is that a setting in php.ini? I've had the same problem with my options-reading.php page and although I bumped up the memory_limit in php.ini to 32M it hasn't allowed the page to display.

  9. jcow
    Member
    Posted 7 years ago #

    I believe this is a setting in Apache not php. I am not sure how to change it though. The IT guy on the server had to go in and do it.

  10. Bodhipaksa
    Member
    Posted 7 years ago #

    Thanks for that advice. I'll talk to my web host.

  11. jcow
    Member
    Posted 6 years ago #

    For the sake of posterity, I did want to add that this is definitely a PHP setting and not Apache.

    You can change it in the php.ini file.

    Just in case someone stumbles across this later. good luck.

Topic Closed

This topic has been closed to new replies.

About this Topic